2D 作図
2D 作図は AutoCAD に準じています。リボン、コマンド ライン、ダイナミック入力、ステータス バーの作図補助のトグルがあります。AutoCAD を知っていれば、そのまま使えます。ホームページの「作成 › 2D 作図」から開始します。
画面
- リボン:「ホーム」タブに、作成、修正、注釈、画層、プロパティ、ユーティリティの各パネルがあります。「挿入」タブには、ブロック、ブロック定義、参照、3D ビューのパネルがあります(ブロックと属性、外部参照、3D からビューを取り込むを参照)。「注釈」タブには、文字、寸法(現在の寸法スタイルのドロップダウンを含みます)、表のパネルがあります。「管理」タブには、クリーンアップ(名前削除
PURGE)、図面設定(単位UNITS、線種LINETYPE、線の太さLWEIGHT、作図補助設定DSETTINGS)、スタイル(文字、寸法、表、マルチ引出線のスタイル)、参照(外部参照パレットXREF、アタッチXATTACH)の各パネルがあります。ボタンは、入力した場合と同じコマンドを開始します。ツールチップにはコマンド名と別名が表示されます。「ビュー」タブにはビューポート ツール(UCS アイコン、ナビゲーション バー)、モデル ビューポート、名前付きビュー、ビジュアル スタイルの各パネル、「出力」タブには印刷(印刷、バッチ印刷、ページ設定管理、プレビュー)と書き出し(PDF、DXF)のパネルがあります。レイアウト タブではさらに「レイアウト」タブ(新規作成、ページ設定、レイアウト ビューポート〔矩形状、ポリゴン、モデル空間/ペーパー空間〕、ビューを作成〔3D ビューを挿入、ビューを更新〕)が使えます。名前付きビュー、ビューポート、表示、レイアウト、ビューポート、印刷を参照。 - パネル展開:パネル タイトルの横に ▾ があるものは、クリックするとあまり使わないツールが展開されます。たとえば、作成パネルの点、構築線、レイ、境界作成、リージョン、等分割、間隔指定点、ドーナツ、修正パネルの延長、面取り、部分削除、点で部分削除、結合、長さ変更、位置合わせ、ポリライン編集、円形状配列複写、パス配列複写、配列複写を編集、和、差、交差、グループ、グループ解除、グループ編集とグループ選択のトグル、ユーティリティ パネルの計測、距離、面積、座標値、リスト、質量プロパティ、点スタイル、単位、名前削除です。ツールをクリックするか、マウスを離すと閉じます。
- キャンバス:暗いモデル空間、十字カーソル、左上のビューポート コントロール「[-][上面][2D ワイヤフレーム]」、左下の UCS アイコン。ステータス バーで、暗い背景と明るい背景を切り替えられます。
- プロパティ パレット:Ctrl+1。選択中は、画層、色などのプロパティを直接変更できます。右側のプロパティ列は折りたためます:タイトルバーの ‹/› で隠し、ウィンドウ右端のハンドルで再表示します。内側の区切り線をドラッグして幅を変更できます(細くして離すと折りたたみ、ダブルクリックで既定の幅、区切り線にフォーカスして矢印キーで微調整)。開閉と幅はワークスペースごとに記憶されます。CAD では Tab はダイナミック入力用で、パネルは隠しません。
- コマンド ライン:キャンバスの下にあります。F2 で履歴を展開します。Ctrl+9 で表示/非表示を切り替えます。
- ステータス バー:モデル/レイアウト タブ、座標、グリッド、スナップ、直交モード、極トラッキング、オブジェクト スナップ トラッキング、オブジェクト スナップ、ダイナミック入力、全画面作図、注釈尺度、単位、保存状態。左クリックで切り替え、右クリックで設定を開きます。
- ワークスペースの切り替え:右上とステータス バーで、「CAD 作図」と「ベクターデザイン」を切り替えられます。同じ図面を 2 つの画面で扱います。
コマンド ライン
- いつでも入力するとコマンド ラインに入ります。先にクリックする必要はありません。
- Enter または Space で確定します。何も入力せずに Enter を押すと、直前のコマンドを繰り返します。Esc はキャンセルしますが、それまでの結果は残ります。
- プロンプトのオプションは、クリックするか、その文字を入力して選べます。たとえば「閉じる」は
Cを入力します。山かっこ内の値が既定値で、Enter で受け入れます。 - 右クリックでショートカット メニューが開きます。コマンド実行中は先頭が「Enter」、それ以外は「直前のコマンドを繰り返す」です。
- 別名と正式名のどちらも使えます。たとえば
LでもLINEでも構いません。オートコンプリートの一覧もあります。まだ実装されていないコマンドを入力すると、その名前と「近日公開」と表示されます。 - 接頭辞:
_は英語名、-はコマンド ライン版(ダイアログなし。例:-OSNAP)、'は透過コマンド(ほかのコマンドの実行中に動作。例:'Z、'P)。 - 1 つのコマンドが、元に戻す 1 回分です。コマンドの実行中に Ctrl+Z を押すと、そのコマンド全体を取り消します。
- IME で入力した全角の記号と数字は、半角として扱われます。
座標入力
x,yは絶対座標、@dx,dyは相対座標、d<aは極座標、@d<aは相対極座標です。- 数値を 1 つだけ入力すると、ダイレクト距離入力になります。カーソルの方向に、その距離だけ進みます。
- ダイナミック入力(F12)がオンのとき、最初の点のあとの
x,yは相対座標になります。絶対座標にするには#を先頭に付けます。Tab で長さを固定して、角度の欄に移動します。 - 点を指定するプロンプトでは、スナップの一時的な指定を入力できます。
END、MID、CEN、INT、PER、TAN、NEAなど、またはスナップをオフにするNONです。修飾:FRO(基点)、M2P(2 点間中点)、TT(一時トラッキング点)。どれも次の 1 点にだけ有効です。
コマンドと別名
別名の表は acad.pgp の一部です。「利用可能」のコマンドは今すぐ使えます。「近日公開」のコマンドは、入力するとメッセージが表示され、別のコマンドと取り違えられることはありません。下の表はソースコードから自動生成されています。
| コマンド | エイリアス | 機能 | 状態 |
|---|---|---|---|
| 作成 | |||
LINE | L | 線分 | 利用可能 |
PLINE | PL | ポリライン | 利用可能 |
CIRCLE | C | 円 | 利用可能 |
ARC | A | 円弧 | 利用可能 |
RECTANG | REC | 長方形 | 利用可能 |
RECTANG | RECTANGLE | 長方形 | 利用可能 |
POLYGON | POL | 正多角形 | 利用可能 |
ELLIPSE | EL | 楕円形 | 利用可能 |
SPLINE | SPL | スプライン | 利用可能 |
XLINE | XL | 構築線 | 利用可能 |
POINT | PO | 点 | 利用可能 |
DDPTYPE | PTYPE | 点スタイル管理 | 利用可能 |
DONUT | DO | ドーナツ | 利用可能 |
HATCH | H | ハッチング | 利用可能 |
HATCH | BH | ハッチング | 利用可能 |
-HATCH | -H | ハッチング(コマンド ライン) | 利用可能 |
HATCHEDIT | HE | ハッチング編集 | 利用可能 |
REGION | REG | リージョン | 利用可能 |
UNION | UNI | 結合 | 利用可能 |
SUBTRACT | SU | 差分 | 利用可能 |
INTERSECT | IN | 交差 | 利用可能 |
BOUNDARY | BO | 境界 | 利用可能 |
MTEXT | MT | マルチテキスト | 利用可能 |
MTEXT | T | マルチテキスト | 利用可能 |
TEXT | DT | 単一行テキスト | 利用可能 |
DDEDIT | ED | 文字を編集 | 利用可能 |
TABLE | TB | 表 | 利用可能 |
TABLESTYLE | TS | 表スタイル | 利用可能 |
STYLE | ST | 文字スタイル | 利用可能 |
| 修正 | |||
MOVE | M | 移動 | 利用可能 |
COPY | CO | コピー | 利用可能 |
COPY | CP | コピー | 利用可能 |
ROTATE | RO | 回転 | 利用可能 |
SCALE | SC | 拡大縮小 | 利用可能 |
MIRROR | MI | ミラー | 利用可能 |
OFFSET | O | オフセット | 利用可能 |
TRIM | TR | トリム | 利用可能 |
EXTEND | EX | 延長 | 利用可能 |
FILLET | F | フィレット | 利用可能 |
CHAMFER | CHA | 面取り | 利用可能 |
ARRAY | AR | 配列複写 | 利用可能 |
ERASE | E | 削除 | 利用可能 |
EXPLODE | X | 分解 | 利用可能 |
JOIN | J | 結合 | 利用可能 |
BREAK | BR | 切断 | 利用可能 |
LENGTHEN | LEN | 長さ変更 | 利用可能 |
STRETCH | S | ストレッチ | 利用可能 |
PEDIT | PE | ポリラインを編集 | 利用可能 |
MATCHPROP | MA | プロパティ マッチング | 利用可能 |
DRAWORDER | DR | 表示順序 | 利用可能 |
ALIGN | AL | 整列 | 利用可能 |
DIVIDE | DIV | ディバイダ | 利用可能 |
MEASURE | ME | メジャー | 利用可能 |
| ブロック | |||
BLOCK | B | ブロック | 利用可能 |
-BLOCK | -B | ブロック(コマンド ライン) | 利用可能 |
BEDIT | BE | ブロック エディタ | 利用可能 |
-INSERT | -I | 挿入(コマンド ライン) | 利用可能 |
INSERT | I | 挿入 | 利用可能 |
WBLOCK | W | ブロック書き出し | 利用可能 |
ATTDEF | ATT | 属性定義 | 利用可能 |
ATTEDIT | ATE | 属性編集 | 利用可能 |
GROUP | G | グループ化 | 利用可能 |
-GROUP | -G | グループ化(コマンド ライン) | 利用可能 |
XREF | XR | 外部参照パレット | 利用可能 |
XATTACH | XA | 外部参照をアタッチ | 利用可能 |
XCLIP | XC | 外部参照をクリップ | 利用可能 |
XBIND | XB | 外部参照をバインド | 利用可能 |
| 注釈 | |||
DIMLINEAR | DLI | 長さ寸法記入 | 利用可能 |
DIMALIGNED | DAL | 平行寸法記入 | 利用可能 |
DIMANGULAR | DAN | 角度寸法記入 | 利用可能 |
DIMRADIUS | DRA | 半径寸法記入 | 利用可能 |
DIMDIAMETER | DDI | 直径寸法記入 | 利用可能 |
DIMCONTINUE | DCO | 直列寸法記入 | 利用可能 |
DIMBASELINE | DBA | 並列寸法記入 | 利用可能 |
DIMORDINATE | DOR | 座標寸法記入 | 利用可能 |
DIMARC | DAR | 弧長寸法記入 | 利用可能 |
DIMJOGGED | DJO | 折り曲げ寸法記入 | 利用可能 |
DIMJOGGED | JOG | 折り曲げ寸法記入 | 利用可能 |
DIMEDIT | DED | 寸法編集(ホーム、新規文字、回転) | 利用可能 |
DIMTEDIT | DIMTED | 寸法値の位置を変更 | 利用可能 |
DIMREASSOCIATE | DRE | 寸法を再関連付け | 利用可能 |
DIMDISASSOCIATE | DDA | 寸法の関連付けを解除 | 利用可能 |
DIMSTYLE | D | 寸法スタイル | 利用可能 |
DIMSTYLE | DST | 寸法スタイル | 利用可能 |
DIMSTYLE | DIMSTY | 寸法スタイル | 利用可能 |
MLEADER | MLD | マルチ引出線 | 利用可能 |
MLEADERSTYLE | MLS | マルチ引出線スタイル | 利用可能 |
| Organize, view, inquiry | |||
LAYER | LA | 画層プロパティ管理 | 利用可能 |
-LAYER | -LA | 画層(コマンド ライン) | 利用可能 |
LINETYPE | LT | 線種 | 利用可能 |
LWEIGHT | LW | 線の太さ | 利用可能 |
PROPERTIES | PR | プロパティ パレット | 利用可能 |
PROPERTIES | CH | プロパティ パレット | 利用可能 |
ZOOM | Z | ズーム | 利用可能 |
PAN | P | パン | 利用可能 |
-PAN | -P | パン(コマンド ライン) | 利用可能 |
-OSNAP | -OS | オブジェクト スナップ(コマンド ライン) | 利用可能 |
DSETTINGS | SE | 作図補助設定 | 利用可能 |
REGEN | RE | 再生成 | 利用可能 |
OSNAP | OS | オブジェクト スナップ設定 | 利用可能 |
DSETTINGS | DS | 作図補助設定 | 利用可能 |
UNITS | UN | 単位 | 利用可能 |
DIST | DI | 距離 | 利用可能 |
MEASUREGEOM | MEA | ジオメトリの計測 | 利用可能 |
AREA | AA | 面積 | 利用可能 |
LIST | LI | リスト | 利用可能 |
PURGE | PU | 名前削除 | 利用可能 |
| Layouts, viewports, plot, files | |||
MVIEW | MV | Create viewports (rectangular, polygonal, lock) | 利用可能 |
MSPACE | MS | Model space inside a viewport | 利用可能 |
PSPACE | PS | Back to paper space | 利用可能 |
-LAYOUT | LO | Layouts (new, copy, delete, rename, set) | 利用可能 |
PLOT | PRINT | Plot (PDF/PNG/SVG) | 利用可能 |
PREVIEW | PRE | 印刷プレビュー | 利用可能 |
| ビュー、イメージ | |||
VIEW | V | ビュー管理 | 利用可能 |
-VIEW | -V | 名前の付いたビュー(コマンド ライン) | 利用可能 |
IMAGE | IM | イメージ パレット | 利用可能 |
EXTERNALREFERENCES | ER | 近日公開 | |
-IMAGE | -IM | イメージ(コマンド ライン) | 利用可能 |
IMAGEATTACH | IAT | イメージをアタッチ | 利用可能 |
IMAGECLIP | ICL | イメージをクリップ | 利用可能 |
IMAGEADJUST | IAD | イメージを調整(明るさ、コントラスト、フェード) | 利用可能 |
-IMAGEADJUST | -IAD | イメージを調整(コマンド ライン) | 利用可能 |
VSCURRENT | VS | 表示スタイル(2D ワイヤフレームのみ) | 利用可能 |
IMPORT | IMP | Import SVG/PDF/AI/DXF | 利用可能 |
EXPORT | EXP | Export SVG/PDF/DXF | 利用可能 |
| エイリアスなし。フルネームを入力 | |||
-ATTDEF | 属性定義(コマンド ライン) | 利用可能 | |
-BEDIT | ブロック エディタ(コマンド ライン) | 利用可能 | |
-BOUNDARY | 境界(コマンド ライン) | 利用可能 | |
-DIMSTYLE | 寸法スタイル(コマンド ライン) | 利用可能 | |
-HATCHEDIT | ハッチング編集(コマンド ライン) | 利用可能 | |
-HYPERLINK | ハイパーリンク(コマンド ライン版) | 利用可能 | |
-LINETYPE | 線種(コマンド ライン) | 利用可能 | |
-PURGE | 名前削除(コマンド ライン) | 利用可能 | |
-VPORTS | ビューポート(コマンド ライン) | 利用可能 | |
-XBIND | 外部参照をバインド(コマンド ライン) | 利用可能 | |
-XREF | 外部参照(コマンド ライン) | 利用可能 | |
3DIMPORT | 3D からビューを読み込み(VIEWBASE と同じ) | 利用可能 | |
AI | AI パネルを開く | 利用可能 | |
AIIMAGE | AI キャンバスを開く(画像 → 要素) | 利用可能 | |
AISKETCH | AI キャンバスを開く(手描き) | 利用可能 | |
ARRAYEDIT | 配列複写を編集 | 利用可能 | |
ARRAYPATH | パス配列複写 | 利用可能 | |
ARRAYPOLAR | 円形状配列複写 | 利用可能 | |
ARRAYRECT | 矩形状配列複写 | 利用可能 | |
BASE | 基点 | 利用可能 | |
BCLOSE | ブロック エディタを閉じる | 利用可能 | |
BHATCH | ハッチング | 利用可能 | |
BREAKATPOINT | 点で切断 | 利用可能 | |
BSAVE | ブロックを保存 | 利用可能 | |
CHAMFERA | 最初の面取り距離 | 利用可能 | |
CHAMFERB | 2 番目の面取り距離 | 利用可能 | |
CTABLESTYLE | 現在の表スタイル | 利用可能 | |
DIM | 寸法 | 利用可能 | |
DIMBREAK | 寸法線切断 | 利用可能 | |
DIMSPACE | 寸法線間隔を調整 | 利用可能 | |
DTEXT | 単一行テキスト | 利用可能 | |
DXFOUT | DXF を書き出し | 利用可能 | |
EXPORTPDF | PDF に書き出し | 利用可能 | |
FIELD | フィールドを挿入(プロジェクト情報、グローバルパラメータ、図番・図面名、日付) | 利用可能 | |
FILLETRAD | フィレット半径 | 利用可能 | |
FIND | 検索と置換 | 利用可能 | |
GRID | グリッド | 利用可能 | |
GROUPEDIT | グループ編集 | 利用可能 | |
HYPERLINK | ハイパーリンク | 利用可能 | |
HYPERLINKOPEN | ハイパーリンクを開く | 利用可能 | |
ID | 点の座標 | 利用可能 | |
IMAGEFRAME | イメージ フレームの表示と印刷 | 利用可能 | |
ISODRAFT | 等角投影図 | 利用可能 | |
ISOPLANE | 等角投影面 | 利用可能 | |
LAYLOCKFADECTL | ロックされた画層のフェード | 利用可能 | |
LAYOUT | Layouts (new, copy, delete, rename, set) | 利用可能 | |
MASSPROP | マス プロパティ | 利用可能 | |
NAVBAR | ナビゲーション バーのオン/オフ | 利用可能 | |
OOPS | 削除したオブジェクトを復元 | 利用可能 | |
ORTHO | 直交 | 利用可能 | |
OSMODE | オブジェクト スナップ ビット値 | 利用可能 | |
PAGESETUP | ページ設定管理 | 利用可能 | |
PDMODE | 点の表示モード | 利用可能 | |
PDSIZE | 点のサイズ | 利用可能 | |
PICKSTYLE | グループ選択 | 利用可能 | |
POLARANG | 極トラッキングの角度増分 | 利用可能 | |
PUBLISH | Publish (multi-sheet PDF) | 利用可能 | |
QDIM | クイック寸法記入 | 利用可能 | |
RAY | 放射線 | 利用可能 | |
REDO | やり直し | 利用可能 | |
REVCLOUD | 雲マーク | 利用可能 | |
REVINFO | リビジョン タグ(番号、日付、説明、作成者) | 利用可能 | |
REVTABLE | リビジョン表(その場で更新) | 利用可能 | |
SELECT | 選択 | 利用可能 | |
SNAP | スナップ モード | 利用可能 | |
TABLEDIT | 表のセルを編集 | 利用可能 | |
TEXTEDIT | 文字を編集 | 利用可能 | |
TOBIM | 2D 平面図を BIM に変換(壁・建具・部屋 → 同じプロジェクトの 3D デザイン) | 利用可能 | |
TRANSPARENCY | イメージの背景の透過 | 利用可能 | |
TRIMEXTENDMODE | トリム/延長モード | 利用可能 | |
U | 1 段階元に戻す | 利用可能 | |
UCSICON | UCS アイコンのオン/オフ | 利用可能 | |
UNDO | 元に戻す | 利用可能 | |
UNGROUP | グループ解除 | 利用可能 | |
UPDATEFIELD | フィールドを更新 | 利用可能 | |
VIEWBASE | 3D からビューを読み込み | 利用可能 | |
VIEWREF | 3D からビューを読み込み(VIEWBASE と同じ) | 利用可能 | |
VIEWUPDATE | 3D からビューを更新 | 利用可能 | |
VIEWUPDATEAUTO | 古くなった 3D ビューを自動更新(0/1) | 利用可能 | |
VPORTS | モデル空間ビューポート | 利用可能 | |
VR3 | 3D からビューを読み込み(VIEWBASE と同じ) | 利用可能 | |
XCLIPFRAME | 外部参照のクリップ境界の表示 | 利用可能 |
オブジェクト スナップと作図補助
ステータス バーのトグルとファンクション キーは、AutoCAD と同じです。全画面表示では、ブラウザーが F11 と F12 を作図ページに渡します。それ以外では、Shift+F11、Shift+F12、またはステータス バーのボタンを使ってください。下の表はソースコードから自動生成されています。
| 切り替え | ファンクションキー | Ctrl キー | 代替キー | コマンド |
|---|---|---|---|---|
| グリッド表示 | F7 | Ctrl+G | GRID | |
| スナップ モード | F9 | Ctrl+B | SNAP | |
| 直交モード | F8 | Ctrl+L | ORTHO | |
| 極トラッキング | F10 | Ctrl+U | POLAR | |
| オブジェクト スナップ トラッキング | F11 | Shift+F11 | OTRACK | |
| オブジェクト スナップ | F3 | Ctrl+F | OSNAP | |
| ダイナミック入力 | F12 | Shift+F12 | DYN |
- オブジェクト スナップは 14 種類あります:端点、中点、中心、図芯、点、四半円点、交点、延長、挿入基点、垂線、接線、近接点、仮想交点、平行。端点、中心、交点、延長は、既定でオンです。
- ステータス バーの「オブジェクト スナップ」を右クリックすると、作図補助設定(
DSETTINGS、DS)が開き、種類にチェックを入れられます。キャンバス上で Shift+右クリックすると、スナップの一時指定メニューが開きます。 - 極トラッキングの角度の増分は、作図補助設定で指定します:90、45、30、22.5、18、15、10、5 度。直交モードと極トラッキングは、同時にはオンにできません。
- オブジェクト スナップ トラッキング:端点や辺の上でカーソルを止めると、トラッキング線が現れます。
- これらの設定は、AutoCAD と同様に、図面ではなくこのコンピューターに保存されます。
- 等角投影図:
ISODRAFTで等角投影面 左(L)、上(T)、右(R) または直交(O) を選びます。等角投影中は直交モード(F8)が現在の投影面の 2 軸に沿います(左=90° と 150°、上=30° と 150°、右=30° と 90°)。Ctrl+E またはISOPLANEで左 → 上 → 右に切り替わり、「<等角投影面 上>」と表示されます。グリッドは等角表示になりません。
選択
- コマンドを実行していないときは、クリックで選択します。左から右は窓選択(完全に含まれるもの)、右から左は交差選択(触れたものすべて)です。押したままドラッグすると投げ縄選択になります。
- Shift+クリックで選択から除外します。Ctrl+A ですべてを選択します。Esc で選択を解除します。カーソルを合わせると、オブジェクトが強調表示されます。
- 選択すると、グリップが表示されます。グリップをドラッグして、ストレッチまたは移動します。マルチ ファンクション グリップでは、さらに多くのオプションが使えます。
- Shift+Ctrl+A でグループ選択(PICKSTYLE、グループを参照)を切り替えます。オンの間は、Ctrl+クリックでグループ内のそのオブジェクトだけを選択できます。Ctrl+W は選択の循環で、ブラウザーが渡すのは全画面作図のときだけです。
- 先選択:先に選択してから
Mと入力すると、そのコマンドは選択済みのオブジェクトを使います。 - Delete で選択を削除します(
ERASEと同じ)。
修正
流れは AutoCAD と同じです。オブジェクトを選択し、Enter で選択を終了し、プロンプトに従って基点や 2 点目をクリックするか、距離、角度、倍率を入力します。プロンプトの文言も AutoCAD に合わせています。1 つのコマンドが、元に戻す 1 回分です。プロンプトの「元に戻す(U)」は、そのコマンド内の直前の操作だけを戻します。修正対象のオブジェクトがロックされた画層にある場合は拒否されます(「オブジェクトはロックされた画層上にあります。」)。ただし、トリムや延長の切り取りエッジと境界エッジは、ロックされた画層にあっても使えます。
- 基本:
MOVE、COPY、ROTATE、SCALE、MIRROR、ERASE、OOPS、STRETCH、MATCHPROP、DRAWORDER、PROPERTIES。 MATCHPROP(MA):コピー元オブジェクトを選び、続けて 1 つ以上のコピー先を選びます。基本プロパティ(色、画層、線種、線種尺度、線の太さ、透過性)と特別なプロパティ(寸法スタイル。文字の文字スタイル、高さ、幅係数。ハッチングのパターン、尺度、角度、間隔など。ポリラインの幅。表スタイル)をコピーします。外部参照、イメージ、表もコピー先にできます。「設定(S)」でプロパティ設定ダイアログを開き、コピーする項目を選べます(ユーザー設定に保存され、図面には入りません)。コマンド全体で 1 回の取り消し単位です。- トリム
TRIM(TR)、延長EXTEND(EX):既定は「クイック」モードです。表示されているすべてのオブジェクトが切り取りエッジまたは境界エッジとして扱われ、トリムする部分を直接クリックします。何もない場所をクリックして 2 点でフェンスを引くか、ボタンを押したままドラッグしてフリー フェンスを描けます。Shift を押しながらクリックすると、トリムと延長が切り替わります。「モード(O)」で「標準」に切り替えると、先に切り取りエッジまたは境界エッジを選択し(Enter=すべて)、続いてオブジェクトをクリックします。「エッジ(E)」で、暗黙の交点まで延長するかどうかを設定します。ほかに、窓選択(C)、フェンス(F)、削除(R)、元に戻す(U) のオプションがあります。クイック モードでは、交点のないオブジェクトは丸ごと削除されます。閉じたオブジェクトをトリムするには、交点が 2 つ必要です。円、閉じたオブジェクト、構築線は延長できません。 - オフセット
OFFSET(O):距離を入力するか(2 点をクリックして距離を測ることもできます)、「通過点(T)」で通過点をクリックします。続いてオブジェクトを選択し、オフセットする側をクリックします。「複数(M)」は最新のコピーから連続してオフセットし、「消去(E)」は元のオブジェクトを削除し、「画層(L)」は現在の画層と元の画層のどちらに置くかを選びます。リアルタイムでプレビューされます。楕円とスプラインをオフセットした結果はスプラインになります。 - フィレット
FILLET(F):既定の半径は 0 です。オプションは、半径(R)、トリム(T)、複数(M)、ポリライン(P)(ポリライン全体のすべての角)です。2 つ目のオブジェクトを選ぶときに Shift を押したままにすると、半径に関係なく鋭角でつなぎます。平行な 2 本の線の間は半円でつなぎます。2 つのオブジェクトが同じ画層にあるときは、新しい円弧もその画層に作成され、そうでない場合は現在の画層に作成されます(色、線種、線の太さ、面取りも同じ規則です)。 - 面取り
CHAMFER(CHA):距離(D)(2 つの距離)、角度(A)(長さと角度)、方式(E) でこの 2 つを切り替えます。ほかにトリム、複数、ポリラインがあります。直線セグメントだけが対象で、平行な線にはメッセージが表示されます。 - 部分削除
BREAK(BR)、点で部分削除BREAKATPOINT:BREAK は、オブジェクトを選択したときにクリックした位置が 1 点目になり、続いて 2 点目をクリックすると、間の部分が削除されます。「1 点目(F)」で 1 点目を別に指定することもできます。円は 1 点目から 2 点目まで反時計回りに削除されます。BREAKATPOINT は、1 点でオブジェクトを 2 つに分け、すき間はできません(円は分割できません)。 - 結合
JOIN(J):端点がつながる線分、円弧、開いたポリラインを 1 本のポリラインにまとめます(端と端がつながると閉じます)。同一線上の線分は 1 本の線に、同じ円上の円弧は 1 つの円弧または円にまとめます。円、閉じたポリライン、文字はスキップされ、コマンド ラインにスキップした数が表示されます。元のオブジェクトが円弧(または楕円弧)だけの場合は、「閉じる(L)」で完全な円(または楕円)にできます。 - 長さ変更
LENGTHEN(LEN):オブジェクトをクリックすると、まず現在の長さが表示されます。オプションは、増減(DE)、パーセント(P)、全体(T)、ダイナミック(DY) です。線分、円弧、開いたポリライン、楕円弧、開いたスプラインに使えます(スプラインは短くすることだけができます)。 - 位置合わせ
ALIGN(AL):オブジェクトを選択し、続いて 1~3 組の「元の点、目標点」をクリックします。1 組=移動、2 組=移動と回転で、位置合わせ点に合わせて尺度変更するかどうかを確認します。3 組の場合、3 点目が反対側にあると鏡像になります。リアルタイムでプレビューされます。 - 分解
EXPLODE(X):ポリラインは線分と円弧に分解されます(幅は失われます)。ブロック参照は内容に分解されます(属性値は失われ、属性定義はラベルを表示する文字に戻ります)。ハッチングはパターンの線に分解されます(塗りつぶしは分解されません)。寸法は線、円弧、文字に、マルチテキストは単一行文字になり、グループは解除されます。分解を許可しないブロックと MINSERT は分解できません。 - ポリライン編集
PEDIT(PE):線分や円弧をクリックすると、ポリラインに変換するかどうかを確認します。オプションは、閉じる/開く、結合、幅(全セグメントを同じ幅に)、スプライン解除、反転、元に戻すです。「複数(M)」で複数を一度に処理でき、結合ではあいまい距離と結合タイプ(延長、追加、両方)を設定できます。スプラインを選んだ場合は、精度も尋ねられます。 - PEDIT の曲線と頂点:「フィット(F)」は各頂点の組を接線円弧でつなぎ、曲線がすべての頂点を通ります。「スプライン(S)」は頂点を制御点にした滑らかな曲線にします。「スプライン解除(D)」は、フィットまたはスプラインのあとでポリラインが変更されていなければ元の頂点に戻し、そうでなければ円弧を直線化します。頂点が少なすぎる場合は、メッセージが表示されます。「頂点を編集(E)」は、現在の頂点に X 印を付けます。オプションは、次(N)、前(P)、部分削除(B)(2 つの頂点を指定し、「実行(G)」でその間のセグメントを削除してポリラインを分割)、挿入(I)、移動(M)、再作図(R)、直線化(S)、幅(W)(次のセグメントの開始幅と終了幅)、終了(X) です。線種生成は近日公開です。
- システム変数:
FILLETRAD(フィレット半径)、CHAMFERA、CHAMFERB(面取り距離)、TRIMEXTENDMODE(0=標準、1=クイック)は直接入力できます。これらは図面に保存され、コマンドと一緒に元に戻ります。トリム、オフセット、面取り、ハッチングの設定も、同様に図面に保存されます。
配列複写
関連配列複写は AutoCAD と同じ動作です。配列は 1 つのオブジェクトとして扱われ、あとから列数、行数、間隔、アイテム数を変更できます。元のオブジェクトは配列に置き換えられ、新しい配列は現在の画層に作成されます。配列を移動、回転、尺度変更、ミラーすると、全体として動きます。ロックされた画層上のオブジェクトは、元のオブジェクトとして選択されません。
ARRAY(AR):オブジェクトを選択し、続いて種類を選びます:矩形状(R)、パス(PA)、円形状(PO)。既定は矩形状です。ARRAYRECT、ARRAYPOLAR、ARRAYPATHは、その種類を直接開始します。「ホーム › 修正」の配列複写ボタンは矩形状配列複写を作成します。円形状配列複写、パス配列複写、配列複写を編集は、修正パネルの展開部にあります。- 矩形状:既定は 4 列 × 3 行で、間隔は元の幅(高さ)の 1.5 倍です。オプションは、関連(AS)、基点(B)、カウント(COU)、間隔(S)(または「単位セル(U)」:2 つのコーナーをクリックして両方の間隔を指定)、列(COL)、行(R)、レベル(L) です。列と行では、「合計(T)」を選ぶと、最初と最後の列(行)の間の距離を入力できます。
- 円形状:最初に中心点をクリックします。既定は、360° を埋める 6 個で、アイテムは回転します。オプションは、アイテム(I)、アイテム間の角度(A)、全体の角度(F)(正=反時計回り、負=時計回り。-360 から 360 の範囲で、0 は不可)、行(ROW)(外側へ向かうリング)、アイテムを回転(ROT) です。アイテムを回転しない場合は、移動だけが行われます。
- パス:パスとなる曲線を選択します(元のオブジェクトにはできません。パスは配列にコピーされるため、元の曲線をあとで変更しても反映されません)。方式(M) は、等分割(D)(アイテムを均等に配置。開いたパスでは両端に 1 個ずつ)か、間隔指定(M)(間隔で配置。既定ではパスに収まるだけ)です。ほかに、アイテム(I)、行(R)、アイテムを位置合わせ(A)(アイテムをパスの接線方向に向ける)があります。
- オプションの指定が終わったら、Enter を押すか、終了(X) を選びます。コマンド全体が、元に戻す 1 回分です。関連(AS) で「いいえ」を選ぶと、コマンドの終了時に配列が個別のオブジェクトに分解されます。
- リボンの「配列複写作成」タブ:コマンドの実行中に表示され、列(またはアイテム)、行、レベル、プロパティ、閉じるのパネルがあります。数値欄は、Enter を押すか欄から移動したときに適用され、Esc で元に戻ります。コマンドを実行していないときに関連配列複写を 1 つ選択すると、同じタブが「配列複写」タブに切り替わり、変更のたびに元に戻す 1 回分になります。
ARRAYEDIT:関連配列複写を選択して、パラメータを変更します(オプションは作成時と同じです)。同じ配列を共有する別のコピーがある場合は、選択したものだけが変わります。EXPLODEは、配列を関連付けのない個別のオブジェクトに分解します。DXF では、配列は無名ブロックの INSERT として、パラメータを XDATA に付けて書き出されます。AutoCAD では通常のブロック参照として見え、Synhedra に読み戻すと配列として復元されます。- 上限:アイテム数 × 元のオブジェクト数は 20,000 まで(アイテム数は最大 100,000)で、大きすぎる場合はメッセージが表示されます。2D 図面にはレベルが 1 つしかないため、レベルを指定しても結果は変わりません。
- グリップ編集:自動調整配列を選択すると、挿入点(配列全体を移動)以外に配列グリップが表示されます。矩形:2 列目=列間隔、最後の列=列数、2 行目=行間隔、最後の行=行数、対角=列数と行数。円形:2 番目=アイテム間の角度、最後=アイテム数(360° のときはなし)、行間隔と行数。パス:計測の 2 番目=間隔、最後=アイテム数。ディバイダの 2 番目=アイテム数。行間隔と行数。グリップをクリック(赤くなる)、移動でライブ プレビュー、もう一度クリックで確定。1 回の編集が元に戻す 1 回分です。
- キー ポイント、接線方向、式による編集と、ソースを編集、アイテムを置換、配列をリセットは近日公開です。
リージョンとブール演算
REGION(REG):閉じたポリライン、円、楕円、スプライン、ベクター パス、および端と端がつながって閉じたループになる線分と円弧を、リージョンに変換します。元のオブジェクトは削除され、リージョンは最初の元のオブジェクトの画層とプロパティを引き継ぎます。面積が 0 のループや自己交差するループは受け付けられず、コマンド ラインに作成したリージョンの数と拒否したオブジェクトの数が表示されます。ロックされた画層上のオブジェクトはスキップされます。- 和
UNION(UNI)、交差INTERSECT(IN):2 つ以上のリージョンを選択します。リージョン以外の選択したオブジェクトは除外されます。差SUBTRACT(SU):引かれる側のリージョンを選択して Enter を押し、続いて引くリージョンを選択します。結果は最初のリージョンのプロパティを引き継ぎます。結果が空になる場合は、そのリージョンが削除され、メッセージが表示されます。 MASSPROP:リージョンの面積、周長、境界ボックス、図心、慣性モーメント、慣性乗積、回転半径、図心まわりの主モーメントと主軸方向を一覧表示します。最後に、解析結果をファイルに書き込むかどうかを確認し、「はい」を選ぶと massprop.mpr がダウンロードされます。- リボン:リージョンは作成パネルの展開部、和、差、交差は修正パネルの展開部、質量プロパティはユーティリティ パネルの展開部にあります。
LISTはリージョンの面積と周長を表示します。DXF では、リージョンは通常のパス ジオメトリとして XDATA の目印付きで書き出され、Synhedra に読み戻すとリージョンとして復元されます。AutoCAD では REGION オブジェクトにはなりません。
等分割、間隔指定点、点スタイル
- 等分割
DIVIDE(DIV):線分、円弧、円、ポリライン、楕円、スプラインのいずれかを選択し、分割数(2 ~ 32767)を入力します。開いたオブジェクトでは、分割数より 1 つ少ない点が置かれ(両端には置かれません)、閉じたオブジェクトでは始点から始まります。 - 間隔指定点
MEASURE(ME):オブジェクトを選択し、分割する長さを入力します(2 点をクリックして長さを測ることもできます)。開いたオブジェクトは、クリックした位置に近い端から測り、閉じたオブジェクトは始点から測ります。アイテムが 32767 個を超える場合は、より大きな長さを指定してください。 - どちらも「ブロック(B)」オプションで点の代わりにブロックを配置できます。ブロック名を入力し、ブロックをオブジェクトに位置合わせするかどうかを選びます(位置合わせすると、各ブロックが接線方向に回転します)。点やブロックは現在の画層に置かれ、オブジェクト自体は変更されないため、ロックされた画層上のオブジェクトでも使えます。新しい点は「直前」選択セットになり、
Pでもう一度選択できます。コマンド全体が、元に戻す 1 回分です。 - 点スタイル
DDPTYPE(PTYPE):20 種類の点スタイルと点のサイズ(画面に対する相対値または絶対単位)を指定するダイアログです。PDMODEとPDSIZEは値を直接入力できます。設定は図面に保存され、元に戻せます。リボン:等分割と間隔指定点は作成パネルの展開部、点スタイルはユーティリティ パネルの展開部にあります。
グループ
GROUP(G):先にオブジェクトを選択してGと入力すると、名前のないグループがすぐに作成されます(*A1、*A2、… と命名)。選択なしで開始した場合は、「名前(N)」と「説明(D)」でグループの名前と説明を指定してから、オブジェクトを選択します。グループ名は*で始められず、< > / \ " : ; ? * | , = `を含められず、重複できません。-GROUP(-G):コマンド ライン版です。オプションは、?(グループを一覧表示)、追加(A)、削除(R)、分解(E)、名前変更(REN)、選択可能(S)、作成(C) です。すべてのメンバーを削除すると、グループも削除されます。順序(O) は近日公開です。UNGROUPはグループを解除します(ベクターデザインのグループも対象)。GROUPEDITには、オブジェクトを追加(A)、オブジェクトを削除(R)、名前変更(REN) があります。ロックされた画層上のメンバーは変更されません。- グループ選択
PICKSTYLE:オンのとき、グループのメンバーをクリックするとグループ全体が選択され(グループが選択可能でない場合を除く)、Ctrl+クリックではそのオブジェクトだけが選択されます。Shift+Ctrl+A または修正パネルの「グループ選択」ボタンで切り替えます。これは個人設定で、図面には保存されません。グループ、グループ解除、グループ編集は修正パネルの展開部にあります。DXF では、名前付きグループの説明と選択可能の設定が保持されます。
ハッチング
HATCH(H、BH、BHATCH):閉じた領域の内側をクリックするか(点をクリック)、「オブジェクトを選択(S)」で境界を選びます。最初の境界が見つかるとすぐに表示され、複数の領域を続けてクリックして 1 つのハッチングにまとめられます。Enter または「閉じる」で確定し、Esc で破棄します。境界にすき間がある場合は、その部分が赤い円で示されます。つなぐか、許容差を大きくしてください。境界として使われるのは、表示されているオブジェクトだけです。- 「ハッチング作成」タブ:コマンドの実行中は、リボンがこのコンテキスト タブに切り替わります。境界(点をクリック、オブジェクトを選択)、パターン(サムネイル ギャラリー)、プロパティ(タイプ:ソリッド、パターン、ユーザー定義、色、背景色、透過性、角度、尺度。ユーザー定義では間隔と二重線に変わります)、原点、オプション(自動調整、島の検出:標準、外側、無視、許容差)、閉じる。コマンドを実行していないときにハッチングを 1 つ選択すると、同じタブが「ハッチング エディタ」になります。変更のたびに、元に戻す 1 回分になります。
- CN-* パターン:独自に設計した 38 種類の CN-* パターンと SOLID を内蔵しています。断面のハッチング、金属、ガラス、木材、コンクリート、土、石、れんが、タイル、床、屋根、断熱材が含まれます。断面系のパターンは用紙上のミリメートルで定義されているため、尺度には印刷尺度を設定します(1:100 なら 100)。れんが、タイル、床、屋根などは実寸で定義されているため、尺度は 1 にします。コマンド ラインでパターン名を入力すると、ANSI31、AR-CONC などの一般的な名前は近い CN-* パターンに対応付けられます。
?を入力すると一覧が表示されます。 - 自動調整(associative):既定でオンです。境界のオブジェクトを移動、ストレッチ、またはグリップで変更すると、ハッチングも更新され、元に戻す同じ 1 回分にまとまります。ハッチング自体だけを移動した場合、境界のオブジェクトを削除した場合、境界を広げて切り離した場合は、関連付けが解除されます。ロックされた画層にある関連ハッチングは再計算されません。
HATCHEDIT(HE):既存のハッチングを編集します(関連付けの解除、島スタイル、プロパティ、原点、関連付けの再設定)。-HATCH(-H)と-HATCHEDITはコマンド ライン版で、コンテキスト タブは開きません。BOUNDARY(BO):領域の内側をクリックして、閉じた境界ポリラインを作成します(島を含みます)。-BOUNDARYも同様です。- プロパティ マッチング:「ハッチング作成」タブと「ハッチング エディタ」タブの「オプション」パネルにプロパティ マッチングがあります(コマンド ラインでは
MAと入力)。別のハッチングをクリックすると、そのパターン、タイプ、尺度、角度、色、背景色、透過性、島検出、画層が適用されます。原点、関連付け、すき間の許容差は現在の設定のままです。 - 境界としてのブロック:ブロック参照も境界として使えます(内容が展開され、入れ子は 8 階層まで)。関連ハッチングは、ブロックを移動、回転、尺度変更すると再計算されます。ハッチング、寸法、グループ、点、非表示のオブジェクト、オフまたはフリーズされた画層上のオブジェクトは、境界として使われません。
- 関連ハッチングのコピー:コピー、配列複写、元を残すミラー、グリップによるコピー、貼り付けで境界のオブジェクトも一緒にコピーされた場合、コピーされたハッチングはコピーされた境界に関連付けられます。そうでない場合、コピーは関連付けられません。シード点とパターンの原点は、移動、回転、尺度変更、ミラーに追従します。
- 境界(エディタ):「ハッチング エディタ」では、「点を指定」で境界を追加し、「削除」でハッチングから境界を削除します(たとえば島。最も外側の境界は削除できません)。展開部には、「再作成」(ハッチングに沿ったポリラインまたはリージョンの境界を作成し、必要に応じてハッチングを再び関連付けます)と「境界オブジェクトを表示」(関連ハッチングのみ)があります。
- 詳細オプション:オプション パネルに「注釈」があります。展開部には、すき間の許容差(0~5000)、島の検出、描画順序(指定しない、最背面へ移動、最前面へ移動、境界の背面へ移動[既定]、境界の前面へ移動。
HPDRAWORDER)があり、作成中は「個別のハッチングを作成」(複数の領域を一度に指定すると、それぞれが別のハッチングになります。HPSEPARATE)、編集中は「個別のハッチング」ボタンもあります。プロパティ パネルの展開部には「ハッチングの画層オーバーライド」があります(HPLAYER。作成中は「現在を使用」)。 HATCHEDITのコマンド ライン オプション:関連付けの解除(DI)、スタイル(S)、プロパティ(P)、描画順序(DR)、境界を追加(AD)、境界を削除(R)、境界を再作成(B)、関連付け(AS)、個別のハッチング(H)、原点(O)、注釈(AN)、ハッチング色(CO)、画層(LA)、透過性(T)。-HATCHにも、描画順序(DR)、注釈(AN)、透過性(T) が加わります。- グラデーションは未対応です。
ブロックと属性
- リボンの「挿入」タブ:「ブロック」パネルに、挿入、ブロック作成、ブロック書き出しがあり、「ブロック定義」パネルに、属性定義、属性編集があります。「ブロック」パネルにもブロック エディタがあります。
BLOCK(B):「ブロック定義」ダイアログが開きます:名前、基点(点を選択)、オブジェクト(オブジェクトを選択し、保持、ブロックに変換、削除から選択)、均一に尺度変更、分解を許可、説明。名前がすでにある場合は、再定義するかどうかを確認します。-BLOCK(-B)はコマンド ライン版で、元のオブジェクトは削除されます。INSERT(I):「挿入」ダイアログが開きます:現在の図面にあるブロックから選び(プレビューあり)、挿入点、尺度、回転は画面上で指定するか直接入力でき、「分解」にチェックを入れることもできます。属性を持つブロックでは、属性値を順に確認します。図面にまだブロックがない場合は、先にBLOCKで作成するよう案内されます。レイアウト タブでは、INSERTは図枠を挿入します(レイアウト、ビューポート、印刷を参照)。-INSERT(-I)はコマンド ライン版です。WBLOCK(W):ブロック、図面全体、または選択したオブジェクトを新しい DXF ファイル(AutoCAD 2000 形式)として書き出してダウンロードします。基点が新しい図面の原点になります。ATTDEF(ATT):「属性定義」ダイアログが開きます:モード(非表示、固定、検証、既定値、位置を固定)、タグ(空白は使えず、大文字で保存されます)、プロンプト、既定値、挿入点、文字の高さと回転。ブロックを作成するときに、属性定義も一緒に選択します。-ATTDEFはコマンド ライン版です。ATTEDIT(ATE):ブロック参照を 1 つ選択し、ダイアログで属性値を変更します。固定属性は変更できません。- ブロック エディタ
BEDIT(BE):「ブロック定義を編集」ダイアログが開きます。一覧(プレビューと説明付き)からブロックを選び、OK をクリックします。先にブロック参照を選択してからBEと入力すると、そのブロックが一覧で選択済みになります。「挿入」タブのブロック エディタ ボタンや、CAD 作図の通常のブロック参照のダブルクリック(属性値を持つブロック、配列、無名ブロックを除く)でも開けます。-BEDITはコマンド ライン版です(?で編集できるブロックを一覧表示)。ブロック エディタはモデル空間でのみ開き、無名ブロック、ダイナミック ブロック、ベクターデザインの記号は編集できません。 - 編集中:ブロックの内容が基点を 0,0 にしてモデル空間に配置され、そのほかのオブジェクトは一時的に非表示になり、選択もスナップもできません。リボンは「ブロック エディタ」コンテキスト タブに切り替わり、ブロックを保存、属性定義、基点、よく使う作図ツールと修正ツール、ブロック エディタを閉じるが表示されます。
BASEで新しい基点を指定できます(ブロック エディタ内でのみ)。エディタを開いている間は、印刷、パブリッシュ、インポート、エクスポート、レイアウトやワークスペースの切り替え、AI パネルを開くことはできず、WBLOCK、VIEWBASE、VIEWUPDATEは拒否されます。先にブロック エディタを閉じてください。 BSAVE:現在の内容でブロックを再定義し、すべての参照が更新されます。説明、分解を許可、均一に尺度変更などの設定は保持されます。内容を空にすることはできません。BCLOSE:ブロック エディタを閉じます。未保存の変更がある場合は、変更を保存する、破棄して閉じる、キャンセル(エディタに残る)のいずれかを確認します。閉じたあと、開いてから閉じるまでのすべての操作が、元に戻す 1 回分になります。破棄した編集をやり直すことはできません。一時的な内容は自動保存もエクスポートもされません。別の図面に切り替えると、変更を破棄したものとして、ブロック エディタが閉じられます。
外部参照
AutoCAD の外部参照にならい、別の DXF 図面をこの図面に参照として配置します。リボンの「挿入 › 参照」パネルに、「アタッチ」(XATTACH、XA)、「クリップ」(XCLIP、XC)、「外部参照」(XREF、XR)があります。
- 元は DXF ファイル、または同じプロジェクトの 2D デザイン:ブラウザーはコンピューター上のファイル パスにアクセスできないため、アタッチすると DXF の内容を読み取ってこの図面に保存し、パスにはファイル名だけを残します。元のファイルが変更されたら、外部参照パレットで「リロード…」を押して、もう一度ファイルを選んでください。DWG ファイルは、先に AutoCAD で DXF として保存してください。.lsm ファイルはアタッチできません。入れ子の外部参照(参照の中の参照)には対応していません。参照内のブロック、属性、ほかのプログラムの寸法は、通常のジオメトリに展開されます。線、ポリライン、円弧、円、点、楕円、スプライン、構築線、レイ、文字、複数行文字、ハッチング、ベクター パス以外のオブジェクトはスキップされ、一覧表示されます。ファイルは 192 MB までで、画面を止めずにバックグラウンドで解析されます。読み込まれるのは最大 100,000 個のオブジェクトで、INSUNITS に従ってこの図面の単位に換算されます。図面に保存される内容が約 4 MB を超えると警告が表示されます。保存のたび、元に戻す履歴、クラウドのデザイン サイズ上限のすべてに加算されるため、先に AutoCAD で簡略化することを検討してください。
XATTACH:DXF ファイルを選ぶと「外部参照をアタッチ」ダイアログが開きます:名前(既定はファイル名)、参照タイプ(アタッチメントまたはオーバーレイ)、挿入点、尺度(均一尺度を含む)、回転(3 つとも画面上で指定できます)、読み取り専用のブロック単位とオブジェクト数。名前は、図面内のブロックや別のファイルの外部参照と同じにはできません。同じファイルを同じ名前でアタッチすると、別の参照になります。尺度、回転、タイプは次回のアタッチに引き継がれます。入れ子には対応していないため、現在はアタッチメントとオーバーレイの違いは表示されるタイプだけです。- 同じプロジェクトの 2D デザインを元にする:「参照ファイルを選択」ダイアログの下にある「または:同じプロジェクトの 2D デザイン」に、同じプロジェクト(または同じ未分類)にあるあなたの他の 2D デザインと、他の人から共有されてこのプロジェクトに置かれている 2D デザインが一覧表示されます。1 つ選んで「このデザインを使用」を押すと(「☁ クラウドから」は先にクラウドから最新版を取得します。接続は 1 回)、同じ「外部参照をアタッチ」ダイアログが開き、名前の既定値はデザイン名です。図面に記録されるのはデザイン ID です(共有されたデザインは、元に戻せない ID を記録し、共有リンクは記録しません)。パレットのパス列には「デザイン:名前」と表示されます。元のデザインが変更されると、パレットを開いたときにステータスに「(元に新しい版があります)」が付きます。その行を選んで「リロード」を押すと、ファイルを選ばずにそのデザインを直接読み直します。「☁ クラウドからリロード」は先にクラウドの最新版を取得します。元の図面内の外部参照は取り込まれません(1 階層のみなので、2 つの図面が互いに参照しても循環しません)。元の図面が 3D から読み込んだビューは通常のジオメトリになります。自分自身は参照できず、共有された図面からあなたの他のデザインを読むこともできません。
- 外部参照パレット
XREF:画面をふさがず、ほかのコマンドの途中でも開けます。列は、参照名、ステータス(ロード済み、アンロード、見つかりません)、サイズ、タイプ、日付、参照数、保存パスです。ツールバーには「DXF をアタッチ…」があり、行を選択して(または右クリックして)「リロード…」(ファイルをもう一度選択)、「アンロード」、「デタッチ」(すべての参照と定義を削除)、「バインド…」を使えます。「開く」は使えません。「タイプ」列をダブルクリックすると、アタッチメントとオーバーレイを切り替えられます。アンロードされていても内容が図面に保存されている外部参照では、メニューに「再ロード(図面内のコピー)」も表示され、ファイルをもう一度選ぶ必要はありません。 - バインド:パレットの「バインド…」には、「バインド」(画層は「名前$0$画層」に名前が変わり、使われていれば $1$、$2$… になります)と「挿入」(画層は名前を維持し、同じ名前の画層はこの図面の画層に統合されます)があります。結果は同じ名前の通常のブロックになり、分解できます。バインドできるのはロード済みの外部参照だけです。
XBIND(XB)、-XBIND:対応しているのは画層(LA)だけです。従属する画層名(「外部参照名|画層」。カンマで複数指定でき、*と?も使えます)を入力すると、その画層がこの図面にバインドされ、「名前$0$画層」に名前が変わります(使われていれば $1$、$2$…)。外部参照自体は外部参照のままです。0 と Defpoints はバインドできず、バインドできるのはロード済みの外部参照だけです。ブロック、寸法スタイル、文字スタイルはアタッチ時にすでに展開され、線種もそのときに統合済みのため、それらのタイプを選んでも理由が表示されるだけです。-XREF:コマンド ライン版で、オプションは ?(一覧)、バインド(B)(常に「バインド」の方法)、デタッチ(D)、パス(P)、アンロード(U)、リロード(R)、オーバーレイ(O)、アタッチ(A) です。名前はカンマで複数指定でき、ワイルドカードの*と?も使えます。ここでのリロードは、内容がまだ図面に保存されているアンロード済みの外部参照を再表示するだけです。図面に内容がない場合は、その行を選択した状態でパレットが開くので、「再ロード…」を押してファイルをもう一度選んでください。新しいファイルを読み込むには、パレットを使ってください。ロックされた画層上に参照がある外部参照はデタッチできません。XCLIP:外部参照またはブロック参照をクリップします(MINSERT 配列は対象外)。オプションは、オン(ON)、オフ(OFF)、削除(D)、ポリラインを作成(P)、新しい境界(N) です。新しい境界は、長方形(R)(既定)、ポリゴン(P)(3 点以上)、ポリラインを選択(S)(閉じていて直線セグメントのみ)から選べます。先に「クリップ反転(I)」を選ぶと内側モードに切り替わり、境界の内側のオブジェクトが非表示、外側が表示されます。線と曲線は境界で切断され、ハッチングは境界との交差部分になり(反転時は差し引かれます)、文字はレイアウト ボックスが境界に触れていれば残り(反転時は完全に内側にある場合を除いて残り)、点と入れ子のブロックは挿入点によって残るか非表示になります。クリップで切り取られた部分は選択もスナップもできません。XCLIPFRAMEでクリップ枠を設定します:0 = 表示しない、1 = 表示して印刷する、2 = 表示するが印刷しない(既定は 2。AutoCAD と同じ)。設定は図面に保存されます。- 画層:外部参照の画層は、画層プロパティ管理に「xrefname|layer」の形式で一覧表示され、フィルタを「外部参照」に設定できます。これらの画層は名前変更、削除、現在に設定はできませんが、オン、フリーズ、ロック、印刷、色、線種、線の太さ、透過性は変更できます。変更は外部参照に保存され、リロード後も保持されます。BYLAYER のプロパティは、外部参照の画層の設定を使います。参照が置かれている画層をフリーズすると、外部参照全体が非表示になります。アンロードまたは見つからない外部参照は何も表示されません。リボンの「ホーム」タブの画層ドロップダウンには、この図面自身の画層だけが表示されます。
PURGEは外部参照を削除しません(XREF でデタッチしてください)。INSERTとBEDITの一覧にも外部参照は表示されません。AI は外部参照を作成も変更もできません。各操作は元に戻す 1 回分です。
3D からビューを取り込む
3D モデルの平面図、立面図、断面図、アクソメ図を、作図を続けられる 2D の線画としてこの図面に投影し、3D モデルが変わったときに更新します。リボンの「挿入 › 3D ビュー」パネルに、「3D から」(VIEWBASE。VR3、VIEWREF、3DIMPORT でも入力可)と「3D から更新」(VIEWUPDATE)があります。CAD 作図でのみ使えます。投影の計算は Make2D と同じです。
- ソース:同じプロジェクト(フォルダ)内の 3D デザイン、または 3D の Make2D ダイアログからダウンロードした .json ファイル(60 MB まで)。プロジェクトに 3D デザインがない場合は、ファイルだけを選べます。
- ビュー:各レベルの平面図(切断高さは変更でき、既定はレベルのビュー範囲。レベルがない場合は、モデルの最下部から 1.2 m の位置で切った平面図が 1 つ)、北、南、東、西の立面図、4 方向のアクソメ図、3D デザイン内の断面(傾斜した断面は未対応)。既定では、最下層の平面図とアクティブな断面にチェックが入っています。一度に取り込めるのは最大 16 ビューです。
- オプション:隠れ線(CN-HIDDEN 線種、既定はオフ)、つながった線をポリラインにまとめる、ビューごとに 1 つのブロック(チェックなし=ばらばらの線)、ビュー ラベル(名前と尺度)、尺度(既定は 1:100 または任意)、注釈尺度と線種尺度をそれに合わせる。モデル空間は常に 1:1 の実寸で、尺度はラベルの高さ、注釈尺度、線種尺度、レイアウトのビューポートにだけ影響します。
- 配置先:モデル空間、またはモデル空間に加えて各ビューごとの新しいレイアウト(収まる最小の横向き A4 ~ A0 用紙に、ロックされたビューポートを配置)。挿入点:画面上で指定、3D の原点に合わせる(平面図はワールド座標に置かれます)、または X と Y を入力。複数のビューは左から右へ横一列に並びます。
- 画層:カテゴリ別(A-WALL-CUT、A-DOOR、A-GLAZ、A-PROJ、A-HIDDEN など)または Make2D の画層別(それぞれを CAD の画層に割り当てられます)。既定では、画層名の先頭に「ビュー名$」が付くため、ビューごとに表示のオンとオフを切り替えられます。ブロック参照とビュー ラベルは A-VIEW 画層に置かれます。
- 取り込みは、元に戻す 1 回分です。各ビューは、ソースと設定を記憶します(XDATA に保存されるため、DXF の往復後も残ります)。1 回の取り込みで作成されるオブジェクトは最大 150,000 個です。それを超える場合は、ビューを減らすか、隠れ線をオフにしてください。
VIEWUPDATE:すべて(A)、選択(S)、強制(F) を選びます。3D モデルが変わっていないビューは「最新」と報告されます。それでも再計算するには、強制を選びます。ビューにユーザー自身の編集(変更、削除、ロックしたオブジェクト)がある場合は、最初にそれが一覧表示され、更新を続けるかどうかを確認します(既定は「いいえ」)。ブロック内に追加したオブジェクトは保持されます。ソースがこの図面のプロジェクトにない、削除された、または読み込めないビューは更新されません。.json ファイルから取り込んだビューは、もう一度取り込む必要があります。計算中に Esc でキャンセルできます。更新は、元に戻す 1 回分です。- 古くなったビューと自動更新:読み込んだ各ビューは作成時の 3D のフィンガープリントを記憶します。3D デザインが変更されると(投影に影響する変更のみ。壁、レベル、パラメータなど。ノードグラフ上のノード移動、シーン、カメラは対象外)、右上に「3D から読み込んだ N 個のビューが古くなっています」というバーが表示されます(操作は妨げません)。モデル タブと、古いビューを表示しているレイアウト タブにはオレンジの点が付きます。[更新]は古いビューだけに
VIEWUPDATEを実行します(編集がある場合は先に確認)。[自動更新]をオンにするかVIEWUPDATEAUTOを 1 にすると(図面に保存、既定 0)、3D 変更後、編集やロックのない古いビューはバックグラウンドの Worker で自動更新されます(コマンド終了後に 1 回の元に戻す操作として適用)。編集したビューはバーに残り、確認が必要です。2D の編集は VIEWWRITEBACK を使ったときだけ 3D に書き戻されます。 - フィールド(FIELD、UPDATEFIELD):
FIELDは自動更新される文字を挿入します。プロジェクト情報(同じプロジェクトの 3D デザインのプロジェクト名、案件番号、住所、発行日…)、グローバルパラメータ(長さ、面積、角度は単位付き)、図番・図面名(レイアウト名「A-101 - 1 階平面図」=図番 A-101、図面名 1 階平面図)、日付(2026-10-20、2026/10/20、民国 115.10.20)。[図枠を挿入]で配置した図枠も、変更していないプロジェクト名、作図、照査、日付、図番、図面名の属性がフィールドになります。図面を開いたとき、VIEWUPDATEの後、UPDATEFIELD(選択またはすべて)で 3D デザインを読み直し、値が変わったものだけ更新します(1 回の元に戻す操作)。グラフで駆動されるグローバルパラメータはバックグラウンドで 3D 全体を評価します。3D デザインを読めない場合(別のデバイス、共有された 2D、削除済み)は前回の文字を保持し、右上に「N 個のフィールドが 3D ソースを読み込めません(古い可能性があります)」と表示します。[フィールドを更新]で再試行できます。フィールドはオブジェクトの XDATA(CN_FIELD)に保存され、DXF の往復でも保持されます。解決後の文字もオブジェクトに保存されるため、オフラインやビューアでも表示されます。1 図面あたり最大 5,000 個、各 500 文字。 - 2D の編集を 3D に書き戻す(VIEWWRITEBACK):3D から読み込んだ線、ドア・窓の記号、タグは、どの 3D 要素から来たかを覚えています。書き戻せる編集:壁の線の平行移動(3D の壁が移動し、接続する壁が伸縮し、壁上のドア・窓も一緒に動く)、ドア・窓の記号(ホスト壁に沿って移動)、ファミリ部材の線。ドア・窓タグの文字の変更(=マーク)。部屋名・部屋番号の変更(レベル平面には部屋タグが入ります)。2 つの 3D オブジェクトに関連付けられた長さ寸法・平行寸法の文字の上書きを数値にする(例:5000)=2 番目の参照の要素を移動して距離をその値にする(3D 平面で寸法値をクリックして変更するのと同じ。DIMLFAC も適用)。編集すると青いバー「2D で 3D から読み込んだ要素を N 個編集しました。3D に書き戻せます」が表示されます。「3D に書き戻す」をクリックするか
VIEWWRITEBACKを入力します(書き戻す(A)/関連付け解除(D)/キャンセル(C))。書き戻しは、まずソースを確認し(このプロジェクト内の自分の 3D デザインで、別のタブで開かれておらず、ビューが古くないこと)、3D エディタと同じ書き戻し規則で 3D デザインを変更し、新しい 3D で影響を受けるビューを更新します。2D では 1 回の元に戻す操作で、Ctrl+Z は 3D も元に戻します(その後 3D が変更されていた場合は 2D だけ元に戻し、通知します)。グローバルパラメータで駆動される値(例:ドア位置をグローバルパラメータに関連付け)は書き戻さず、どのグローバルパラメータかをメッセージで示します。3D でグローバルパラメータを変更してください。書き戻せない編集(ストレッチ、回転、トリム、タグの位置だけの移動、ポリライン壁の一部、図面を開き直して元の位置が分からない移動)は理由とともに表示されます。「関連付け解除」を選ぶと通常の 2D オブジェクトとして残し、以後VIEWUPDATEは同じオブジェクトを生成しません(ビューごとに最大 100 個)。同じビューに書き戻せない編集が残っている場合は、関連付けを解除するか更新で置き換えるかを先に確認します。制限:アクソメと傾いた断面は書き戻せません。立面・断面は水平移動のみ。寸法値はブロックでない(ばらの)ビューの関連寸法のみ。リアルタイム共同編集がオンのとき、または編集可能で共有されているデザインは未対応です(変更は共同編集の借用ルールに従う必要があるため、3D で変更してください)。一度に最大 500 件。 - 2D 平面図を BIM に変換(
TOBIM):リボン「挿入 › 3D ビュー › BIM に変換」またはTOBIMで平面図のオブジェクトを選択(事前選択、またはALL)すると、2D 平面を同じプロジェクトの 3D デザインの壁、建具、部屋として認識します(モデラー内の双方向作業の「2D → 3D」側で、汎用の DWG→BIM 変換ではありません)。壁=名前に wall/壁 を含む画層(例:A-WALL。または先に「壁の画層」オプションで指定、* 使用可)上の平行線の対(線、ポリラインの直線区間)で、間隔 8~60 cm=壁厚。中心線は 2 本が重なる区間に引き、L/T 字の角は隣の壁の中心線までつなぎます。建具=名前に door/window/門/窓 を含むブロック(最も近い壁に配置、幅はブロックの壁方向の幅)、または同じ壁上の 0.5~3 m の切れ目(既定はドア。切れ目に建具ブロックがあればその種類。作成時に切れ目の両側の壁を 1 枚にまとめます)。部屋=閉じたポリラインの中、または四方とも認識した壁に当たる文字(名前=文字、1 領域に 1 つ)。認識結果はまず図面に重ねてプレビュー(シアン=壁、黄=建具、緑=部屋、灰色=作成しない。一時的で図面には残りません)。右のパネルで項目ごとに選び、ドア/窓を切り替え、3D デザイン、レベル、壁タイプ(自動=厚さが最も近いもの)を選んで「作成」で 3D デザインに書き込みます。2D 側は 1 回の元に戻す操作です(元のオブジェクトは変換済みを記録し、再度TOBIMを実行すると既定でスキップ)。Ctrl+Z で 3D も元に戻ります(その後 3D が変更されていれば 2D だけを戻して通知)。保護は VIEWWRITEBACK と同じです:この 2D 図面があなたのワークスペースのデザインであること(共有された図面は変換しない)、対象が同じプロジェクトのあなた自身の 3D デザインで、別のタブで開かれておらず、リアルタイム共同編集中でないこと、書き込み前にその間 3D が変更されていないことを確認します。外部参照は同じプロジェクトのあなた自身の 2D デザインのみ(ファイル由来はスキップ)。3D から読み込んだオブジェクトは変換しません。2D の原点=3D の原点。上限:一度に壁 2,000 枚、建具 2,000 個、部屋 500 室、壁画層の線分 20,000 本(多い場合は範囲を分けて選択)。 基点:パネルの「基点(2D → 3D)」で 2D の基点(座標を入力、または「選択」を押して図面上をクリック。コマンド オプションBA)と、それを置く 3D の点(m)を指定します。既定は 2D の原点=3D の原点です。1 枚の図面に複数の階を並べて描いた平面は、先にMOVEで重ねなくても、階ごとに自分の基点(例:同じ外壁の角)を指定すれば済みます。ALL(すべて)で選択すると範囲を続けて聞かれます。窓で囲むと範囲内でまだ(どの 3D 設計にも)変換していないオブジェクトだけ、Enter で図面全体の未変換オブジェクトを対象にします。別の階の未変換の文字(階の表示など)は取り込まれなくなりました。 - 事務所標準:画層ルール、フェーズ、コンポーネントのブロック、注釈、自動寸法:ウィザードの「事務所標準」欄には 5 つのオプションがあり、新しくインポートしたビューにだけ影響します。以前にインポートしたビューは更新しても従来のままです(画層が突然変わったり寸法が増えたりしません)。
- 画層の割り当てルールを適用(既定でオン、「カテゴリ別」のみ):
LAYERRULES(またはDRAFTRULES)と入力して「画層と寸法のルール」ダイアログを開き、「カテゴリ、切断状態、フェーズ、タグ、レベル → 画層」と色(ACI)、線の太さを設定します。たとえば壁の切断線を「壁-切断」に置けます。ルールは順に照合され、最初に一致したものが有効です。一致しなければ従来の A-WALL-CUT、A-DOOR… になります。ダイアログには 2 組のサンプルがあります(台湾の事務所の中国語画層、フェーズ別の NCS 画層)。同じプロジェクトの 3D 設計の平面ルール(プロジェクトレベル。3D の平面セルも同じ設定を使用)も合わせて適用され、この図面のルールが優先されます。「この図面にコピー」でセット全体を取り込んで編集できます。カテゴリは英語コードで書きます(wall、door、window、floor、column、beam、roof、stair、component、grid、tag、keynote、room…)。タグとレベルにはワイルドカード * が使えます。ルールを変更したら、インポート済みのビューはVIEWUPDATEで「強制」を選んで再生成します。 - フェーズ別の画層:3D でフェーズが「既存」の要素は
-EXST画層(グレー)、このフェーズで解体するものは-DEMO(破線)、新築には接尾辞を付けません。画層ルールに「フェーズ」条件がある場合はルールが優先されます。 - ドアと窓、ファミリのコンポーネントをブロック化:同じタイプ・同じ形状(90° の倍数の回転と左右の鏡像を含む。鏡像の挿入は X 尺度 −1)のドア、窓、コンポーネントは 1 つのブロック定義(名前は
3D-タイプ-コード)を共有し、インスタンスごとに 1 つの挿入になります。属性は集計表の列(タイプ、タグ、レベル、幅、高さ、窓台、プロジェクトパラメータ。非表示なので図面の見た目は変わりません)です。ATTEXT(EATTEXT、DATAEXTRACTION)と入力すると属性を CSV に抽出します。見出しに「集計表の列」を選ぶと、列名は 3D 集計表の CSV と同じになります。ブロック全体の移動は VIEWWRITEBACK で 3D に書き戻せます(ドアと窓は母体の壁に沿って移動)。ドラッグした属性の位置は更新しても保持されます。 - タグと注釈タグをマルチ引出線で描き、構造通り芯を追加:平面図のタグ、注記タグ、複数カテゴリタグ、マテリアルタグは、複数行文字+引出線+矢印になり(タグ付けされた 3D 要素を記憶)、構造通り芯と通り芯番号は
S-GRID、S-GRID-TEXT(中心線)に置かれます。ドラッグしたタグは更新しても置いた位置に残ります(引出線は追従)。ビューの表示/グラフィックスで「通り芯」カテゴリをオフにすると、通り芯は追加されません。 - 寸法ルールによる自動寸法(既定でオン、寸法ルールがある場合のみ生成):ダイアログの「自動寸法」で、種類(全体寸法、連続寸法、通り芯間隔、各要素の幅、最長辺に沿う)、カテゴリ、対象物からの距離(用紙上の mm)、画層(既定は A-ANNO-DIMS)を設定します。寸法はビューと一緒に生成・更新され、3D には書き戻されません。ビューあたりルール寸法は最大 2,000 個です。
- レイアウトと印刷スタイル:新しいレイアウトにインポートするとき、レイアウトルールが用紙と図枠ブロックを決めます(図枠はこの図面内のブロックであること)。平面ビューに適用した 3D のビューテンプレート(表示/グラフィックス)は、ビューポートの画層オーバーライドになります。非表示のカテゴリはビューポートで凍結され、色と線の太さはテンプレートに従います。ダイアログの「ビューテンプレート → 印刷スタイル(STB)」でテンプレートから名前付き印刷スタイルテーブルを生成でき、印刷時にそれを選ぶとテンプレートどおりに印刷されます。
- レイアウト規則の尺度:3D デザインを選ぶと、レイアウト規則(この図面のものを優先し、なければ 3D デザインの平面規則)に尺度があれば、ウィザードがその尺度をあらかじめ選択して表示します。変更もできます。
- 断面/立面のレベルとマテリアル タグ、ルール更新:
LAYERRULESの自動寸法に 2 種類が加わりました:レベル線+ラベル(断面と立面でレベルごとに水平線 1 本、右端にレベル記号と「1F +0.00」)とマテリアル タグ(要素ごとに引出線+マテリアル名。BIM マテリアルから取得:壁・床=タイプの構成層のコア マテリアル、その他=オブジェクトのマテリアル)。断面と立面だけに適用(平面には描かない)、既定の画層は A-ANNO-DIMS、VIEWUPDATE でまとめて再生成します。距離は用紙上の mm です(例:1:100 の 6 mm=0.6 m)。各ビューは作成時のこの図面のルール(画層対応と寸法ルール)を記憶します。後でルールを変えると、通知バーに「ルール更新:N 個のビューは古い図面ルールで作成されています」と表示され(3D が変わっていなくても表示。期限切れ扱いではありません)、「新しいルールで更新」でそれらのビューにVIEWUPDATEを実行します(元に戻すは 1 回)。この機能より前に読み込んだビューは対象外です。
- 画層の割り当てルールを適用(既定でオン、「カテゴリ別」のみ):
名前付きビュー、ビューポート、表示
VIEW(V):ビュー管理。現在のビューとモデル ビューを一覧し、現在に設定、新規作成(現在の表示または窓で指定)、名前変更、削除ができます。[OK]でまとめて適用(1 回の取り消し単位)。リボン「表示 › 名前付きビュー」のドロップダウンから直接復元できます。-VIEW(-V)はコマンド ライン版で、オプションは AutoCAD と同じ ?/Delete/Orthographic/Restore/Save/sEttings/Window です。名前付きビューはモデル空間のみ。復元するとその範囲が収まるようにズームし、タイル表示のときは現在のビューポートに適用されます。VPORTS:モデル空間のタイル表示ビューポート。ダイアログで標準の構成(1 つ;2 つ:垂直、水平;3 つ:右、左、上、下、垂直、水平;4 つ:均等)を選ぶか、名前を付けて保存します。-VPORTS:Save/Restore/Delete/Join/SIngle/?/2/3/4。2、3、4 は現在のビューポートを分割し、SIngle は 1 つに戻し、Join は現在のビューポートと隣を結合します。クリックしたビューポートが現在になり、それぞれ個別に画面移動・ズームします(取り消しの対象外)。レイアウト タブではMVIEWを使います。UCSICONは左下の UCS アイコン、NAVBARはナビゲーション バーのオン/オフです。どちらも個人の設定で、このブラウザーに記憶され、図面には保存されません。2D 製図にはワールド座標系しかないため、UCSICONのほかのオプションは効果がありません。VSCURRENT(VS):2D 製図のビジュアル スタイルは「2D ワイヤフレーム」だけです。ほかを選ぶとメッセージが出ます。
ラスター イメージ
IMAGEATTACH(IAT):PNG または JPEG ファイルを選び、「イメージをアタッチ」ダイアログで名前、挿入点、尺度、回転角度(画面上で指定または値を入力)を設定してから図面に配置します。尺度は図面単位でのイメージの幅です。1 回のアタッチが 1 回の取り消し単位です。- 上限:ファイル 30 MB、1 辺 16384 ピクセル、合計 4000 万ピクセル。超えるとデコード前に拒否します。図面には縮小したスナップショット(長辺 2048 ピクセル)が保存されます。デザイン全体、取り消し履歴、保存データがスナップショットを持ち運ぶため、大きいときは警告が出ます。イメージ定義は最大 1000 個です。
IMAGE(IM):イメージ パレット。名前、状態、サイズ、参照数、パスを一覧し、アタッチ、再ロード(ファイルを選び直す)、アンロード、デタッチができます。-IMAGE(-IM):?/Detach/Path/Reload/Unload/Attach。IMAGECLIP(ICL):ON/OFF/Delete/New boundary。新しい境界はポリライン選択、ポリゴン、長方形で指定でき、クリップの反転もできます。IMAGEADJUST(IAD):明るさ、コントラスト、フェードをダイアログで調整します(OK=1 回の取り消し単位)。-IMAGEADJUST(-IAD)はコマンド ライン版です。TRANSPARENCY:PNG の透明ピクセルを透明で表示します(ON/OFF)。IMAGEFRAME:0=フレームを表示しない、1=表示して印刷(既定)、2=表示するが印刷しない。- イメージは移動、回転、尺度変更、鏡像、複写、配列複写ができ、グリップとスナップはブロックと同じです。分解はできません。
- DXF:書き出しでは IMAGE エンティティとして、元ファイルのパスとピクセル サイズだけを書きます(AutoCAD の外部イメージと同じ)。図面内のスナップショットは DXF に書かれません。DXF から読み込んだイメージはフレームとパスだけで、状態は「見つかりません」になります。イメージ パレットで「再ロード」してファイルを選ぶと表示されます。
照会
照会コマンドは図面を変更しないため、読み取り専用の図面でも使えます。結果はコマンド ラインの履歴(F2)に表示されます。DIST、ID、AREA は透過的に実行できます(例:'DIST)。
DIST(DI):2 点間の距離、XY 平面での角度、X と Y の差を表示します。「複数点(M)」で合計の長さを累計します。ID:1 点をクリックすると、その点の座標を表示します。AREA(AA):多角形の角を順にクリックするか、「オブジェクト(O)」で円、ポリライン、楕円、スプライン、ハッチングなどを選択して、面積と周長を表示します。「面積加算(A)」「面積減算(S)」で合計面積を累計します。角をクリックしている間に「円弧(A)」に切り替えると接線円弧のセグメントを描け(「2 点目(S)」で 3 点円弧、「閉じる(CL)」で最初の点まで円弧で閉じる)、「長さ(L)」で直前のセグメントの方向に長さを入力することもできます。LIST(LI):選択したオブジェクトの種類、画層、空間、ハンドルと、種類ごとのデータ(たとえば、ハッチングのパターンと面積、ブロックの名前と属性)を一覧表示します。MEASUREGEOM(MEA):距離(D)、半径(R)(円弧、円、ポリラインの円弧セグメント。直径も表示)、角度(A)、面積(AR) を計測します。角度:円弧を選ぶと挟角、円を選んでから 2 点目をクリック、2 本の線を選ぶと線の間の角度(どちらの角度になるかはクリック位置で決まります)。または Enter を押して、頂点と 2 つの端点をクリックします。2D 図面には計測できる体積がありません。「クイック」計測は近日公開です。- ハイパーリンク
HYPERLINK(Ctrl+K):オブジェクトを選択してアドレスと説明を入力します。ハイパーリンクはオブジェクトの XDATA(PE_URL、AutoCAD と同じ、DXF でも保持)に保存されます。-HYPERLINKの削除(R) で削除。HYPERLINKOPENで選択オブジェクトのリンクを新しいタブで開きます(http、https、mailto のみ)。オブジェクトのハイパーリンクのみ(領域ハイパーリンクはなし)。 - 雲マーク
REVCLOUD:既定の矩形(R):対角の 2 点を指定。多角形(P):点を順に指定、元に戻す(U)、Enter で終了(3 点以上)。オブジェクト(O):選択したポリラインまたは円を雲マークに置き換えます(画層とプロパティは保持)。弧長(A) で各弧の長さを設定、0=自動(外形の対角線の 8%)。弧は常に外側に膨らみ、1 つの雲マークは最大 5,000 頂点です(密すぎると弧を自動で長くします)。結果は膨らみ付きの通常のポリラインなので、DXF の往復や AutoCAD でも開けます。弧長とモードはこの作業中は記憶されます。 - リビジョンタグとリビジョン表
REVINFO、REVTABLE:REVINFOはリビジョン雲マークを選択し(そのまま Enter でも可)、リビジョン番号、日付(既定は今日)、説明、作図者を順に入力します。選択した雲マークにリビジョンタグが書き込まれ、同時に「現在のリビジョン」に設定されるため、以降REVCLOUDで描いた雲マークには自動的にこのタグが付きます。タグは雲マーク(ポリライン)の XDATA(アプリケーション CN_REV)に保存され、DXF の往復でも保持され、AutoCAD で開いても影響はありません。REVTABLEはタグ付きの雲マークをリビジョン番号ごとにまとめ(大文字小文字を区別せず、自然順)、図面上で左上隅をクリックして文字高さを入力するとリビジョン表(線分+単一行文字:リビジョン、日付、説明、作図者。長すぎる文字は「…」で省略)を作成します。リビジョンを変更した後にもう一度REVTABLEを実行すると、位置は尋ねず、同じ位置・同じ文字高さでその場で更新します。実行ごとに元に戻す操作は 1 ステップです。リビジョン表がロックされた画層にある場合は更新されません。上限:200 行、リビジョン番号 16 文字、日付 24 文字、説明 120 文字、作図者 40 文字。制御文字と双方向文字は除去されます。読み取るのはモデル空間の雲マークのみで、課題へのハイパーリンク(lsm://issue)は提供しません。また、REVCLOUDは外形または変換対象のオブジェクトが 20,000 点を超える場合、別の形状に切り詰めず、メッセージを表示してリビジョン雲を作成しません。
画層
- 画層プロパティ管理
LAYER(LA):リボンの「ホーム › 画層」の「画層プロパティ」ボタン、またはLAを入力します。パレットは画面をふさがず、ドラッグでき、ほかのコマンドの途中でも開けます。列は、状態(✓=現在の画層、ダブルクリックで現在に設定)、名前(ダブルクリックで名前変更)、オン、フリーズ、ロック、印刷、色(ACI 1~255 またはトゥルー カラー)、線種(ロード済みの線種)、線の太さ、透過性(0~90)、説明です。上部には、新規作成、削除、現在に設定、フィルタ(すべて、使用中のすべての画層)、検索があります。変更のたびに、元に戻す 1 回分になります。 - 制限:0 画層と Defpoints 画層は削除も名前変更もできません。現在の画層は削除もフリーズもできません。オブジェクトがある画層(レイアウトやブロック定義の中のオブジェクトを含む)は削除できません。フリーズされた画層は現在に設定できません。画層名は空にできず、255 文字までで、
< > / \ " : ; ? * | = ` ,は使えず、大文字小文字を区別せず重複できません。 -LAYER(-LA):コマンド ライン版です。オプションは、?、作成(M)、設定(S)、新規(N)、名前変更(R)、オン(ON)、オフ(OFF)、色(C)、線種(L)、線の太さ(LW)、印刷(P)、フリーズ(F)、フリーズ解除(T)、ロック(LO)、ロック解除(U) です。画層名はカンマで複数指定でき、ワイルドカードの*と?も使えます。- ロックされた画層のフェード
LAYLOCKFADECTL:ロックされた画層上のオブジェクトは、画面上で薄く表示されます(既定は 50)。-90 から 90 の整数を入力します。0 または負の値でフェードがオフになります(負の値は数値が保持されます)。CAD 作図の画面表示にだけ影響し、印刷やエクスポートには影響しません。図面に保存されます。 - リボンの「画層」パネルのドロップダウンで、現在の画層を直接切り替えられます。「プロパティ」パネルの線種と線の太さのドロップダウンについては、線種、線の太さ、単位、名前削除を参照してください。
- 外部参照の画層は「xrefname|layer」の形式で一覧表示されます。外部参照を参照してください。
線種、線の太さ、単位、名前削除
- プロパティ パネルのドロップダウン:リボンの「ホーム › プロパティ」パネルの線種ドロップダウンには、ByLayer、ByBlock、Continuous、ロード済みの線種、「その他...」(
LINETYPEを開く)があります。線の太さドロップダウンには、ByLayer、ByBlock、既定、24 種類の標準の線の太さ、「線の太さ設定...」(LWEIGHTを開く)があります。選択がある場合は選択したオブジェクトが変更され(元に戻す 1 回分。ロックされた画層上のオブジェクトはスキップされます)、選択がない場合は現在の線種または線の太さが変更されます。色ドロップダウンには ByLayer、ByBlock、標準 7 色、「色を選択...」(インデックス カラー 1–255 とトゥルー カラー)があり、同じように動作します(選択オブジェクト、または現在の色CECOLOR)。 - 線種管理
LINETYPE(LT):線種フィルタ(すべて、使用中、未使用。「フィルタを反転」付き)、ロード...、削除、現在に設定(または行をダブルクリック)、詳細を表示(名前、説明、全体の線種尺度LTSCALE、現在のオブジェクトの尺度CELTSCALE)。ByLayer、ByBlock、Continuous、現在の線種、使用中の線種は削除できません。「ロード...」では、内蔵の CN-* ライブラリ、または選んだ .lin ファイルから線種を選びます。ロード済みのものは再ロードされます。.lin ファイルは 4 MB までです。不正な定義(無効な名前、無効なダッシュ長、64 個を超えるダッシュ指定、予約名、重複した名前)はその定義だけがスキップされ、ダイアログに名前と理由が表示されて、ほかの定義は引き続きロードできます。-LINETYPEはコマンド ライン版で、?(一覧)、ロード(L)(内蔵ライブラリのみ、ワイルドカード可)、設定(S) があります。 - ユーザ定義の線種(
-LINETYPEの作成(C)):名前、説明、.lin の A 行のパターン(例12.7,-6.35,0,-6.35:正=線分、負=間隔、0=点、単位は用紙 mm、LTSCALEで尺度)を入力します。線分、間隔、点のみ(文字、シェイプは不可)、最大 64 要素。既存の名前は上書きの確認があります。定義は図面に保存され(AutoCAD は .lin ファイルに書き込み)、DXF にも書き出されます。 - 線の太さ設定
LWEIGHT(LW):現在の線の太さ、リストの単位(ミリメートルまたはインチ)、線の太さを表示、既定(LWDEFAULT。変更しない限り 0.25 mm)、表示尺度を調整。 - 単位管理
UNITS(UN):長さのタイプ(建築、小数、工学、分数、科学)と精度、角度のタイプ(10 進数の度、度/分/秒、グラード、ラジアン、測量単位)、精度、時計回り、挿入尺度(INSUNITS)、「方向...」で基準角度を設定します(東、北、西、南、その他)。この設定は、コマンド ラインに表示される長さと角度、照会コマンド(DIST、ID、LIST、AREA)、ステータス バーに使われます。入力は 10 進数(図面単位)のほか、単位付きの長さ12'-6 1/2"、10'、6"、500mm、3mも使え、図面単位に換算されます。長さのタイプが建築または工学のときの図面単位はインチです(AutoCAD と同じ)。建築と分数では6 1/2も入力できます。フィート/インチの設計で 3D の「プロジェクト情報 › 単位」がフィート・インチ形式のとき、新しい CAD 図面はインチ、建築の長さ単位(1/16 インチ)、寸法スタイルARCH-IMPERIAL(寸法単位=建築)が既定になります。既存の図面は変わりません。システム変数LUNITS、LUPREC、AUNITS、AUPREC、ANGBASE、ANGDIR、INSUNITS、LTSCALE、CELTSCALE、LWDISPLAY、LWUNITSは直接入力することもできます。 - 名前削除
PURGE(PU):「名前削除」ダイアログには、「削除可能な項目」と「削除できない項目を検索」の 2 つのタブがあります。カテゴリ(ブロック、寸法スタイル、グループ、画層、線種、表スタイル、文字スタイル)にチェックを入れると、下のプレビューに削除される項目が表示されます。オプションは、入れ子になった項目を削除(既定でオン)、長さゼロのジオメトリを削除、空の文字オブジェクトを削除です。「チェックした項目を削除」または「すべて削除」を押します。ダイアログは開いたままで、その中で削除したものはすべて元に戻す 1 回分です。削除できない項目には理由が表示されます(使用中、現在の項目、既定の項目、外部参照、記号、無名ブロック)。参照のない無名の表ブロックと配列ブロック(*T、*U)は削除可能として一覧に表示されます。外部参照内のオブジェクトは、この図面での使用とは数えられません。DXF の読み込みで保持された属性の書式設定で使われている画層、線種、文字スタイルは、使用中として扱われます。「更新」で図面を再分析します。-PURGEはコマンド ライン版で、タイプ(ブロック B、寸法スタイル D、グループ G、画層 LA、線種 LT、文字スタイル ST、表スタイル T、長さゼロのジオメトリ Z、空の文字オブジェクト E、すべて A)、名前、各項目を確認するかどうかを選びます。 - 単位と名前削除は、リボンの「ホーム › ユーティリティ」パネルの展開部と「管理」タブにあります(画面を参照)。
レイアウト、ビューポート、印刷
- レイアウト タブ:ステータス バーの左側に「モデル」タブと各レイアウトのタブがあります。1 つのレイアウトが 1 枚の用紙です。タブを右クリックすると、レイアウトの追加、名前変更、削除、移動、コピーのほか、ページ設定管理、印刷、パブリッシュを開けます。コマンドは
-LAYOUT(LO)です。 - 用紙:標準サイズは ISO A/B、ANSI、ARCH で、横向きまたは縦向きを選べます。
- ビューポート
MVIEW(MV):レイアウトにビューポートを作成します。長方形をドラッグするか、「ポリゴン(P)」で多角形のビューポートを描きます。「フィット(F)」、「ロック(L)」、「オン(ON)」、「オフ(OFF)」もあります。新しいビューポートは既定でモデル全体を表示します。モデル タブでこのコマンドを入力すると、「モデル タブではこのコマンドは使用できません」と表示されます。 - ビューポートの尺度:ビューポートを選択し、ステータス バーのビューポート尺度のプルダウンから尺度を選びます。標準の尺度(1:100 など)はそのまま選べ、それ以外の値は「カスタム…」と表示され、1:75 のような尺度を入力できます。
- ビューポートのロック:ステータス バーのビューポート ロック ボタン、または
MVIEWの「ロック」。ロックすると、ズームや画面移動をしても、ビューポートの尺度とビューは変わりません。 - モデル空間とペーパー空間:
MSPACE(MS)でビューポート内のモデル空間に入り、PSPACE(PS)でペーパー空間に戻ります。ビューポートの内側をダブルクリックするか、ステータス バーの「ペーパー」/「モデル」ボタンでも切り替えられます。ペーパー空間への直接の作図はまだ使えません。ビューポートに入ってから描いてください。 - ページ設定
PAGESETUP:ページ設定管理を開きます。用紙サイズ、印刷範囲(レイアウト、窓、図面範囲、図面範囲設定)、印刷尺度(用紙にフィットを含む)、印刷スタイル テーブル(独自の CN-* スタイルを 5 種類内蔵、.ctb の読み込みも可)、図面の向き、中心に印刷を設定できます。設定したページ設定は「現在に設定」するか、レイアウトに適用できます。 - 印刷
PLOT(PRINT):印刷ダイアログを開きます。まず「プレビュー…」で結果を確認し、PDF または PNG ファイル(ダウンロード)として出力します。印刷はバックグラウンドのワーカーで実行されるため、画面が固まることはありません。 - パブリッシュ
PUBLISH:複数のレイアウトを 1 つの複数ページ PDF にパブリッシュします。一覧でパブリッシュするレイアウトにチェックを入れます。各行にシート名とページ設定があります。 - 図枠:
INSERTまたは「図枠を挿入」でダイアログを開き、図枠を選んで属性(図面名など)を入力します。 - ベクターデザイン ワークスペースの「オブジェクト › アートボードをレイアウトに変換」は、アートボードを 1 枚のシートとロック付きのビューポートに変えます。
- 印刷プレビュー
PREVIEW(PRE):印刷ダイアログを開き、すぐにプレビューを作成します。EXPORTPDF:PDF に書き出し(リボン「出力 › 書き出し」。レイアウト タブではページ設定に従います)。DXFOUT:DXF 書き出し。 - レイアウトに 3D ビューを挿入:レイアウト タブの「レイアウト › ビューを作成 › 3D ビューを挿入」(
VIEWBASE)。ビューの線はモデル空間の既存の内容の右側に置かれ、このレイアウトにはビューごとにロックされたビューポートが 1:尺度値 で作られます。3D を変更したら「ビューを更新」(VIEWUPDATE)で、ビューポートも追従します。そのほかのオプションは3D からビューを取り込むを参照。
文字
- 単一行文字と複数行文字:
TEXT(DTEXT、DT)は単一行文字、MTEXT(MT、T)は複数行文字を作図します。コマンド ラインで、始点、位置合わせ、スタイル、高さ、角度を順に尋ねます(複数行文字は枠の 2 つの角を尋ね、幅や段などのオプションもあります)。パラメーターを入力し終えると、図面上でそのまま編集でき、リボンに「文字エディタ」タブが表示されます。文字入力は 1 回の取り消し操作です。 - 編集
DDEDIT(ED)、TEXTEDIT:既存の文字を編集します。文字を直しても、複数行文字の書式コードは失われません。 - スタイル
STYLE(ST):文字スタイルのダイアログを開きます。使用中の文字スタイルは削除できません。 - 検索
FIND:「検索と置換」を開きます。検索、置換、すべて置換ができ、検索範囲と完全一致も選べます。置換の前に、その箇所が検索後に変更されていないかを確認し、変更されていた場合は検索し直します。1 回の置換で扱える数には上限があります。 - 中国語の組版:繁体字中国語では禁則処理を行います。台湾で使われる中央寄せの句読点は詰めず、全角幅のままです。
表とドーナツ
- ドーナツ
DONUT(DO):内径(既定 0.5。0 = 塗りつぶしの点)と外径(既定 1)を入力し、続けて中心をクリックしてドーナツを配置します。Enter で終了します。直径は入力するか、2 点で指定できます。各ドーナツは、幅を持つ閉じたポリラインです。直径は今回のセッションの間だけ記憶され、図面には保存されません。リボンでは、作成パネルの展開部にあります。 - 表
TABLE(TB):リボンの「注釈 › 表」。「表を挿入」ダイアログには、表スタイル、挿入オプション(挿入点を指定 = 表の左上隅。ウィンドウを指定 = ウィンドウから列幅とデータ行数を算出)、列(1~100、既定 5)、列幅(既定 63.5)、データ行(1~998)、行の高さ(行数、1~100)、1 行目と 2 行目のセル スタイル(タイトル、見出し、データ。それ以外の行はすべてデータ)があります。表のセルは最大 10,000 個です。配置後は、セル A1 から編集が始まります。 - セルの編集
TABLEDIT:セルをダブルクリックするか、表タブの「文字を編集」を押すか、TABLEDIT と入力してセルを選びます。セルに直接入力します:Enter で確定、Alt+Enter または Shift+Enter で改行、Tab と Shift+Tab で次または前のセルに移動(最後のセルで Tab を押すと行が追加されます)、Esc で終了します。 - 「表」コンテキスト タブ:表を 1 つ選択し、コマンドを実行していないときに表示されます。セルをクリックすると現在のセルになり、Shift+クリックで範囲を広げます。行:上に挿入、下に挿入、行を削除。列:左に挿入、右に挿入、列を削除。結合:セルを結合(すべてを結合、行で結合、列で結合)、セルの結合を解除。セルの書式:位置合わせ(スタイルに従うか、9 つの位置から選択)。そのほか、文字を編集と閉じるがあります。各操作は元に戻す 1 回分です。
- 表スタイル
TABLESTYLE(TS):「表スタイル」ダイアログには、スタイルの一覧、現在に設定、削除(Standard、使用中のスタイル、現在のスタイルは削除できません)、新規(選択したスタイルをコピー)があります。修正では、文字スタイル、水平と垂直の余白、グリッド線(罫線)、タイトル、見出し、データそれぞれの文字の高さと位置合わせを設定します。Standard の既定値は、タイトル文字 6、見出しとデータ 4.5、余白 1.5、中央揃えです。OK を押すと、そのスタイルを使うすべての表が、同じ元に戻す 1 回分で再作成されます。CTABLESTYLEで現在の表スタイルを直接設定できます。 - ロックされた画層上の表は編集できません。
寸法記入
寸法記入コマンドとプロンプトは AutoCAD に合わせています。リボンの「注釈」タブにも同じボタンがあります。寸法記入コマンド 1 回が、取り消し操作 1 回分です。
- 長さ寸法
DIMLINEAR(DLI)、平行寸法DIMALIGNED(DAL):2 本の寸法補助線の起点をクリックするか、Enter を押してオブジェクトを 1 つクリックし、最後に寸法線の位置をクリックします。配置前に「複数行文字(M)」「文字(T)」「角度(A)」を選べます。長さ寸法にはさらに「水平(H)」「垂直(V)」「回転(R)」があります。 - 角度寸法
DIMANGULAR(DAN):2 本の線、円弧 1 つ、または円 1 つを選択します。Enter を押すと 3 点指定(頂点と 2 つの端点)になります。 - 半径寸法
DIMRADIUS(DRA)、直径寸法DIMDIAMETER(DDI)、弧長寸法DIMARC(DAR):円弧または円(弧長寸法は円弧、またはポリラインの円弧セグメント)を選択し、寸法線の位置をクリックします。 - 座標寸法
DIMORDINATE(DOR):フィーチャの点をクリックし、次に引出線の端点をクリックします。「X 基準(X)」「Y 基準(Y)」で方向を指定できます。 - 直列寸法
DIMCONTINUE(DCO)、並列寸法DIMBASELINE(DBA):最後に作成した寸法に続けて記入します。「選択(S)」で既存の寸法を起点に選ぶこともできます。並列寸法の間隔は寸法スタイルに従います。 - クイック寸法記入
QDIM:ジオメトリをまとめて選択し、寸法を一度に並べて配置します。モードは直列、千鳥、並列、座標、半径、直径で、「基準点(P)」で基準を変更できます。 - 寸法線間隔を調整
DIMSPACE:基準になる寸法を選び、次に間隔をそろえる長さ寸法または平行寸法を選んで、間隔を入力するか「自動(A)」を選びます。間隔 0 は、同じ線上にそろえます。平行でない寸法はスキップされ、メッセージが表示されます。 - スマート寸法
DIM:オブジェクトにカーソルを合わせてクリックすると、直線には長さ寸法または平行寸法、円弧と円には半径寸法または直径寸法が記入されます。2 点を直接クリックすることもできます。コマンドは Enter または Esc を押すまで繰り返されます。オプションは、角度、並列、直列、座標、「画層(L)」(新しい寸法を指定した画層に置く)、「元に戻す(U)」です。 - 編集
DIMEDIT(DED):「ホーム(H)」で文字を既定の位置に戻し、「新規作成(N)」で文字を変更し、「回転(R)」で文字を回転します。DIMTEDIT(DIMTED):寸法値をドラッグして新しい位置に移動するか、「左(L)」「右(R)」「中心(C)」「ホーム(H)」「角度(A)」を選びます。どちらも先に寸法を選択してから実行できます。 - マルチ引出線
MLEADER(MLD):矢印の位置、ランディングの位置をクリックし、文字を入力します。「オプション(O)」で、ランディング優先または内容優先に切り替えたり、最大ノード数を設定したりできます。スタイルはMLEADERSTYLE(MLS)の管理ダイアログで設定します。作図されるのは、グループ化された線、矢印、文字です。グリップで調整できる引出線オブジェクトではありません。 - プロパティ パレット(Ctrl+1):寸法を選択すると、寸法スタイル、寸法値の上書き(
<>は測定値)、文字の高さ、文字の回転、全体の尺度、精度を変更できます。測定値と関連付けの有無は表示のみです。 - ロックされた画層の寸法は編集されません。コマンドがスキップした数を知らせます。
- 折り曲げ寸法記入
DIMJOGGED(DJO、JOG):リボンの「注釈 › 寸法記入」パネルの「折り曲げ」。円弧または円を選択し、中心位置の優先設定を指定し、寸法線の位置を指定します(複数行文字、文字、角度が使えます)。続けて折り曲げ位置を指定します。中心が用紙の外にある半径の大きな円弧向けです。折り曲げの角度はDIMJOGANG(既定 45°)で、寸法スタイルの「シンボルと矢印」ページで変更できます(5~90°)。寸法は円弧または円に関連付けられ、DIMREASSOCIATEも使えます。 - 寸法線切断
DIMBREAK:リボンの「注釈 › 寸法記入」パネルの「切断」。寸法を選択し、「自動(A)」(寸法と交差するすべてのオブジェクトで切断。既定)、寸法を切断するオブジェクトを指定(Enter で終了)、「手動(M)」(切断点を 2 点指定)、「削除(R)」(すべての切断を解除)のいずれかを選びます。「複数(M)」では、先に複数の寸法を選択してから、切断(B) または削除(R) を選びます。切断されるのは寸法線、寸法補助線、引出線だけで、矢印と文字は切断されません。文字、点、ハッチング、構築線、レイ、グループは切断の原因になりません。切断の大きさは、寸法スタイルの DIMBRK に全体の尺度を掛けた値です(既定 3.75)。寸法スタイルの「シンボルと矢印」ページの「寸法切り取り:切り取りサイズ」で変更できます。自動と指定による切断は、そのオブジェクトが移動すると追従し、オブジェクトが削除されると消えます。手動の切断は、寸法と一緒に移動、尺度変更されます。
関連寸法
- 寸法補助線の起点をクリックするときにオブジェクト スナップ(端点、中点、中心、四半円点、交点、ノード、挿入基点など)が効いていると、その点はオブジェクトに関連付けられます。以後、オブジェクトを移動、ストレッチ、変更すると、寸法も同じ取り消し操作の中で更新されます。
- 関連付けられたオブジェクトが削除されると、その点は関連付けが外れ、寸法はその場に残ります。
- オブジェクトを動かさず寸法だけを移動した場合、位置が合わなくなった点は関連付けが解除されます。AutoCAD と同じ動作です。
- ロックされた寸法(オブジェクトまたは画層)は連動しません。
- 3D モデルから生成したビューの線に記入した寸法は、モデルを変更すると更新されます。元の線が見つからない場合、寸法は以前の位置と値を保ったまま黄色で表示されます。
DIMREASSOCIATEで指定し直してください。 DIMREASSOCIATE(DRE)は点ごとに関連付けを指定し直します。DIMDISASSOCIATE(DDA)は、選択した寸法の関連付けを解除します。プロパティ パレットの「関連」欄に現在の状態が表示されます。
寸法スタイルと異尺度対応
- 新しい図面の既定の寸法スタイルは CN-METRIC です。尺度は 1:100、ペン幅は 0.25 です。これらの値は独自に設計したものです。
ISO-25とStandardは互換のための別名で、同じ値を指します。 DIMSTYLE(D)で「寸法スタイル管理」を開きます。新規作成(開始元のスタイルを選択)、現在のスタイルに設定、矢印、文字スタイル、接頭表記と接尾表記などの修正を行い、「適用」を押します。「シンボルと矢印」ページには、寸法線切断の切断サイズ(DIMBRK)と、半径折り曲げ寸法の折り曲げ角度(DIMJOGANG、5~90°)もあります。CN-METRIC と使用中のスタイルは削除できません。-DIMSTYLEはコマンド ライン版です(保存、復元、ステータス、適用、一覧)。- リボンの「注釈」タブのドロップダウンで、現在の寸法スタイルをすぐに切り替えられます。
- 注釈尺度:異尺度対応の寸法は、モデル空間ではステータス バーの注釈尺度、レイアウトのビューポート内ではビューポートの尺度に合わせて大きさが換算されます。たとえば用紙上で 2.5 の文字は、1:100 では 250 になります。
- 3D の平面モードにある平行寸法 DI は CN-LINEAR を使い、CN-METRIC と同じ値です。
CN-* 線種
- 内蔵の線種ライブラリは、独自に設計した CN-* シリーズ 30 種類で、それぞれに中国語と英語の説明があります。
- AutoCAD で一般的な線種名は、近い CN-* 線種に対応付けられます。古い図面にある旧名称も同様です。
- DXF の線種と寸法も CN-* を通ります。読み込み時、ファイルに含まれる線種定義はそのまま使われます。
- ベクターデザインの破線パネルは DXF の線種として書き出せます。ベクターデザイン › パス ツールを参照してください。
DXF に関する注意
- 通芯の検出:2D CAD で DXF を読み込むと、通芯はそのまま線・円・文字になります。図面の通芯(通芯画層、または通芯記号+番号+長い線)を 3D の構造通芯にするには、3D モデラーの「ファイル ▸ DXF を読み込む…」を使ってください。DXF 通芯 → 構造通芯を参照。
- 書き出しメモ:DXF を書き出すとき、引き継げない内容や書き方が変わる内容(ベクター オブジェクト、パスだけを書き出した外部参照、簡略化されたクリップ境界など)は、コマンド ラインに「書き出しメモ:」として一覧表示されます。
- 寸法:DIMENSION として書き出し、表示用の線、矢印、文字(匿名ブロック)を付けるため、AutoCAD で開くとそのまま表示されます。Synhedra で作成した寸法は、関連付け、スタイルの上書き、注釈尺度を XDATA にも記録し、Synhedra に読み戻すと編集可能な関連寸法として復元されます。DXF の読み込みでは寸法スタイルはファイル内の定義に従い、書き出しではすべての寸法変数を保持します。
- ほかのソフトで作成された DIMENSION はそのまま保持され、書き出し時にもそのまま書き戻されますが、Synhedra では寸法として編集できません。
- 弧長寸法は ARC_DIMENSION として書き出されます。AutoCAD 2004(AC1018)以降でなければ認識されませんが、書き出すファイルは AC1015 のため、警告が表示されます。
- マルチ引出線は通常の線と文字です。DXF でも通常のジオメトリで、MULTILEADER オブジェクトではありません。
- 読み書きできるのは ASCII の DXF だけで、書き出すバージョンは AC1015(AutoCAD 2000)です。DWG には対応していません。
- ブロック:ブロック定義は BLOCK、ブロックの挿入は INSERT として書き出され、尺度、回転、配列(MINSERT)も含まれます。属性がある場合は ATTRIB も書き出されます。
WBLOCKで書き出すファイルも AC1015 です。 - ハッチング:HATCH として書き出し、パターン定義一式を付けるため、AutoCAD で別途 .pat ファイルは必要ありません。関連付けは書き出されませんが、形状はそのまま残ります。Synhedra は XDATA にも目印を付け、Synhedra に読み戻すと編集可能なハッチングとして復元します。ほかのソフトで作成された HATCH は、そのまま保持されます。
- 記号:ベクターデザインの記号も BLOCK と INSERT として書き出します。記号の種類と動的な上書きは、別に XDATA に保存します。AutoCAD は XDATA を無視するため、通常のブロック参照として表示され、上書きは見えません。Synhedra に読み戻すと復元されます。XDATA が AutoCAD の 1 オブジェクトあたり 16 KB の上限を超える場合は、種類だけを書き出し、上書きは Synhedra のファイルに残ります。
- ベクター パス:LWPOLYLINE、SPLINE、HATCH として書き出し、Synhedra 独自の XDATA を付けます。読み戻すとベクター パスとして復元されます。
- 配列複写、リージョン、グループ、3D から取り込んだビュー:配列は無名ブロックの INSERT として、リージョンは通常のジオメトリとして書き出され、パラメータや目印は XDATA に保存されて、読み戻すと Synhedra が復元します。配列のパラメータが XDATA に収まらないほど大きい場合は、通常のブロック参照として書き出され、警告が表示されます。名前付きグループは説明と選択可能の設定を保持します。3D から取り込んだビューの記録も XDATA に保存されます。
- 折り曲げ寸法と寸法線切断:折り曲げ寸法は半径寸法の DIMENSION として書き出され、優先設定点と折り曲げ点は XDATA に保存されます。切断は寸法の無名ブロックに描かれるため、AutoCAD でも表示されます。Synhedra に読み戻すと、どちらも復元されます。
- 外部参照:外部参照の BLOCK として書き出されます(タイプ、ロード済みフラグ、パスとしてのファイル名)。図面に外部参照があると、書き出しの前に「参照」と「内容をバインド」のどちらで書き出すかを尋ねます。参照ではパスだけが書き出され、内容は書き出されません。書き出しメモで受け取る側に元のファイルが必要なことが通知され、外部参照の画層は「name|layer」として書き出されます。内容をバインドでは、ロード済みの外部参照を内容ごと通常のブロックとして書き出します(画層名は「name$0$layer」に変更。図面自体は変わりません)。ロードされていないものはパスだけになります。
XCLIPの境界(反転を含む)は XDATA に保存されるため、AutoCAD ではクリップされない状態で表示されます。XDATA に収まらないほど大きい境界は先に簡略化され、書き出しメモに点数の変化が示されます。DXF から読み戻すと、外部参照には内容がなく(ステータスは アンロード または 見つかりません)、パレットの「リロード…」で各ファイルをもう一度選ぶ必要があります。 - 表:無名ブロック(線と複数行文字)の INSERT として書き出され、表のデータは XDATA に保存されます。ACAD_TABLE ではないため、AutoCAD ではブロックとして扱われます。表スタイルの定義は書き出されず、各表がスタイル設定の独自のコピーを持ちます。
- 属性付きの INSERT:DXF を読み込むとき、ATTRIB が続く INSERT は、属性値を編集できるブロック参照になります。各属性は、画層、色、スタイル、幅係数、傾斜角度、非表示フラグなどの書式を保持し、その形式で書き戻されます。タグが重複する INSERT や、表現できないデータを含む INSERT は保持され、そのまま書き戻されます。
- 単位:$LUNITS、$LUPREC、$AUNITS、$AUPREC、$ANGBASE、$ANGDIR、$INSUNITS、$LWDISPLAY は書き出され、読み戻されます。LWUNITS、LWDEFAULT、線の太さの表示尺度、XCLIPFRAME は Synhedra のファイルにだけ保存されます。
その他のショートカット
| キー | 動作 |
|---|---|
| Ctrl+Z、Ctrl+Y | 元に戻す、やり直し。コマンド U、UNDO、REDO。 |
| Ctrl+1 | プロパティ パレット。 |
| Ctrl+9 | コマンド ラインの表示/非表示。 |
| F2 | コマンド履歴。 |
| Ctrl+A、Shift+Ctrl+A | すべて選択、グループ選択の切り替え。 |
| Ctrl+W | 選択の循環(全画面作図)。 |
| Delete | 選択を削除。 |
| Ctrl+F、Ctrl+G、Ctrl+L、Ctrl+B、Ctrl+U | オブジェクト スナップ、グリッド、直交モード、スナップ モード、極トラッキング。 |
| Ctrl+K | ハイパーリンクを挿入(HYPERLINK)。 |
| Ctrl+E | 等角投影面を切り替え(左 → 上 → 右、ISOPLANE)。 |
| 中ボタンドラッグ、ホイール | パン、ズーム。 |
この表は手作業で管理しています(出典:keys.ts)。
インポート、エクスポート、保存
- 図面は自動保存されます。Ctrl+S はありません。保存状態は、ステータス バーの右側に表示されます。2D の図面は、ブラウザーのデータベース(IndexedDB)に保存されます。
- DXF のインポート:アプリケーション メニュー、または
DXFIN。対応するのは ASCII の DXF だけです。バイナリの DXF は、AutoCAD で ASCII として保存し直してください。DWG は、DXF として保存するか、ODA File Converter で変換してください。 - DXF のエクスポート:アプリケーション メニュー。引き継げない内容については、DXF に関する注意の「書き出しメモ」を参照してください。
- 単位は、デザインの作成時に選びます。長さと角度の表示形式は
UNITSで設定します(線種、線の太さ、単位、名前削除を参照)。 - このサイトでクラウドドライブが設定されている場合(本番サイトではまだ利用できません)は、「ファイル」メニューに「クラウドドライブから開く…」「クラウドドライブに保存…」「クラウドドライブにコピーを保存…」があり、DXF も一緒に保存できます。読み取り専用の図面はドライブに保存できません。外部クラウドドライブを参照してください。
- 写真、スキャンした図面、スケッチを作図オブジェクトに変換するには、
AIIMAGE、AISKETCH、またはアプリケーション メニューの「AI キャンバス(画像/フリーハンド)…」でAI キャンバスを開きます。
近日公開
グラデーション。PEDIT の線種生成。MEASUREGEOM のクイック計測。配列複写のキー ポイント、ソースを編集、アイテムを置換、配列をリセット。-GROUP の順序。ブロック エディタの名前を付けてブロックを保存。これらのコマンドを入力すると、コマンド ラインにメッセージが表示されます。