矢量设计
矢量设计是 2D 图面的第二种界面,仿照 Illustrator:菜单栏、左侧工具栏、灰色画布上的白色画板、右侧属性。它与 CAD 绘图编辑的是同一份图面。这个工作区还在早期阶段;下表会清楚说明哪些功能可用。
进入方式
- 首页“建立 › 2D 绘图”,模板选择“矢量设计:A4 画板 (Illustrator)”。
- 或在任何 2D 图面的右上角或状态栏,切换工作区“CAD 绘图 ⇄ 矢量设计”。每个设计会记住上次使用的工作区。
- 两个工作区共用同一个选取,切换后仍然保留。
工具
单键与 Illustrator 相同。下表由源代码生成。
| 工具 | 快捷键 | Illustrator 名称(英文) |
|---|---|---|
| 选择工具 | V | Selection Tool |
| 直接选择工具 | A | Direct Selection Tool |
| 编组选择工具 | 无 | Group Selection Tool |
| 套索工具 | Q | Lasso Tool |
| 直接选择套索工具 | 无 | Direct Selection Lasso Tool |
| 钢笔工具 | P | Pen Tool |
| 添加锚点工具 | + | Add Anchor Point Tool |
| 删除锚点工具 | - | Delete Anchor Point Tool |
| 锚点工具 | Shift+C | Anchor Point Tool |
| 曲率工具 | Shift+~ | Curvature Tool |
| 直线段工具 | \ | Line Segment Tool |
| 矩形工具 | M | Rectangle Tool |
| 椭圆工具 | L | Ellipse Tool |
| 画笔工具 | B | Paintbrush Tool |
| 斑点画笔工具 | Shift+B | Blob Brush Tool |
| 铅笔工具 | N | Pencil Tool |
| 平滑工具 | 无 | Smooth Tool |
| 路径橡皮擦工具 | 无 | Path Eraser Tool |
| 旋转工具 | R | Rotate Tool |
| 镜像工具 | O | Reflect Tool |
| 比例缩放工具 | S | Scale Tool |
| 宽度工具 | Shift+W | Width Tool |
| 橡皮擦工具 | Shift+E | Eraser Tool |
| 连接工具 | 无 | Join Tool |
| 形状生成器工具 | Shift+M | Shape Builder Tool |
| 符号喷枪工具 | Shift+S | Symbol Sprayer Tool |
| 文字工具 | T | Type Tool |
| 直排文字工具 | 无 | Vertical Type Tool |
| 渐变工具 | G | Gradient Tool |
| 吸管工具 | I | Eyedropper Tool |
| 画板工具 | Shift+O | Artboard Tool |
| 抓手工具 | H | Hand Tool |
| 缩放工具 | Z | Zoom Tool |
绘制与选择
- 矩形 M、椭圆 L:拖动绘制。按 Shift 画正方形或圆,按 Alt 从中心绘制。新对象使用当前的填色与描边(默认为白色填色和 1 pt 黑色描边),画在当前图层。
- 选择 V:单击选取,Shift 加选或减选,拖出方框则碰到即选中。选取的对象会显示定界框:8 个控制点用于缩放,在角点外侧稍远处可旋转。
- 直接选择 A 可选取锚点。编组选择是工具栏按钮。双击编组可进入隔离模式;顶部会出现路径栏。
- 旋转 R、镜像 O、缩放 S:单击设置参考点,拖动进行变换。Alt+单击会打开对话框,可输入精确数值。
- 移动:方向键按一个键盘增量微移,Shift 为十倍,Alt 为先复制再移动。Enter 打开“移动”对话框。
- 智能参考线 Ctrl+U:移动时,边缘和中心会对齐其他对象和画板。
- 属性面板:变换栏位(X、Y、W、H、角度)、对齐、填色与描边。
- 画板工具 Shift+O:拖出新的画板。
- 缩放:Ctrl+0 画板适合窗口大小,Alt+Ctrl+0 全部适合窗口大小,Ctrl+1 100%(每个屏幕像素 1 pt),Ctrl+=、Ctrl+-。
- 直线段工具 \:拖动绘制一条直线(实时形状)。Shift 限制为 45° 的倍数,Alt 从中心绘制。单击打开“直线段工具选项”:长度、角度、线段填色(勾选才保留填色),从单击位置沿角度方向绘制(Alt+单击=单击位置为中点)。会记住上次的值。
- 键盘增量在“编辑 › 首选项 › 常规…”(Ctrl+K)设置,默认 1 pt;同一个对话框还有“缩放描边和效果”。首选项保存在文档中。
选择、变换与对齐
- 套索 Q(Lasso Tool)与直接选择套索:自由形状圈选,两者行为相同,选的是锚点和线段,同 Illustrator。对象的锚点全部被圈住=整个对象被选中;只圈住一部分锚点=部分选择(被圈住的锚点是实心);只有线段穿过、没有锚点在内=选中那一段线段。Shift 加选,Alt 减选,不按修饰键=替换原来的选择。锁定或隐藏的对象不会被选中。
- 选择 › 相同:按填色和描边、填色颜色、描边颜色、描边粗细、不透明度、外观、图形样式选出相同的对象,或选同一图层上的全部对象。
- 变换:“对象”菜单的“移动…”“旋转…”“镜像…”“缩放…”打开对话框输入数值,可以勾选“拷贝”。Ctrl+D 再次变换,“重置定界框”把旋转过的定界框归正。属性面板里的 X、Y、宽、高、角度可以直接输入,也能链接宽高保持等比。
- 对齐(属性面板):水平、垂直对齐,分布,以及分布间距。“对齐到”可选“对齐所选对象”、“对齐关键对象”(先单击所选对象中的一个,把它当作关键对象)或“对齐画板”。
钢笔工具
- 钢笔 P、添加锚点 +、删除锚点 -、锚点 Shift+C 在工具栏的同一格,曲率 Shift+~ 在另一格。按住那一格约半秒、右键单击或点角落的小三角形,展开工具组;Alt 点那一格换成组里的下一个工具。
- 钢笔:单击放尖角锚点,拖动放平滑锚点(两侧手柄对称)。拖动时 Shift 限制在 45° 的倍数;拖到一半按 Alt 打断手柄,只动向外的那一支;按住 Space 移动整个锚点。光标移到起点(出现 o)单击闭合路径。单击最后一个锚点收回它的手柄。单击另一条开放路径的端点,把两条接起来。没在绘制时单击开放路径的端点,可以接着往下画。
- 在选取的路径上,钢笔单击线段=添加锚点,单击锚点=删除锚点;按住 Shift 则改成开始新路径。按住 Alt 暂时变成锚点工具,按住 Ctrl 暂时变成直接选择:画到一半 Ctrl 单击,已画的部分先创建并选中,路径保持开放,可以拖动它的锚点或手柄调整后接着画;Ctrl 单击空白处或别的对象=结束这条路径。
- Enter 或 Esc 完成路径,保留已画的部分。Backspace、Delete 或 Ctrl+Z 删掉最后一个锚点,Shift+Ctrl+Z 把刚删掉的锚点加回来(只在这条路径内,不动文档的撤销记录)。整条路径是一个撤销步骤。智能参考线(Ctrl+U)开启时,会吸附 4 像素内的锚点。
- 添加锚点、删除锚点:单击线段添加锚点,形状不变;单击锚点删除,相邻的曲线重新拟合。按住 Alt 两者互换。
- 锚点工具:单击平滑锚点转成尖角;从锚点拖动拉出对称的手柄;拖单独一支手柄只动那一支(Shift 限制 45°);直接拖动线段改变弯度,直线段也可以拖弯。
- 曲率工具:每单击一下加一点,曲线通过所有的点。Alt 单击或双击点,切换尖角与平滑;拖动点移动;单击线段加点;单击第一点闭合。也能编辑已选取的路径。每一点是一个撤销步骤。
- 锁定、隐藏的对象与文字不能用这些工具编辑。
填色、描边与颜色
- 填色与描边:工具栏下方两个重叠的方块。在前面的那个,就是色板面板、颜色面板和快捷键要改的对象。X 切换前后,Shift+X 互换填色与描边的颜色,D 回到默认(白色填色、黑色 1 pt 描边),/ 设为无,, 回到上次用的颜色。双击方块打开拾色器。改的是选取的对象,也是之后新对象的外观;每次修改是一个撤销步骤。
- 拾色器:色域方块加色相条,数值栏有 HSB、RGB、十六进制与 CMYK。超出印刷色域或不是 Web 颜色时会出现警告图标,单击一下改成最接近的颜色。可以勾选“仅限 Web 颜色”。“颜色色板”切换成色板列表。
- 颜色面板 F6:颜色模式有灰度、RGB、HSB、CMYK、Web 安全 RGB,在面板菜单切换(会记住);菜单另有反相与补色。下方有无、黑、白与色谱条。当前颜色是全局色板时,面板只显示色板名称与色调滑块。
- 按比例调整:RGB、Web 安全 RGB 与 CMYK 模式下,按住 Shift 拖动一个滑块(或按 Shift+方向键),其他滑块按比例一起移动。HSB 与灰度不适用。
- 用键盘操作:色谱条可以用 Tab 聚焦,←→ 改色相、↑↓ 改明暗(Shift 加大步距),每次按键是一个撤销步骤。拾色器的色彩方块用方向键调整饱和度与亮度,色相条用方向键调整色相(Shift=10 倍)。颜色面板与色板面板的 ☰ 菜单打开后,焦点在第一项,↑↓、Home/End 移动,Esc 关闭并回到 ☰ 按钮。
- 色板面板(“窗口 › 色板”):默认有基本色、色环、大地色与灰度组。单击色板应用到前面的方块。全局色板(角落有白色三角形)以名称关联:改色板,所有用到它的对象一起更新,也可以设置色调。专色一定是全局色板。面板菜单有新建色板、新建颜色组(从选取的色板或图稿)、复制色板、删除色板(用到它的对象改成普通颜色)、取消颜色组编组、选择所有未使用的色板、添加使用的颜色、按名称排序、缩览图或列表视图、色板选项。在“色板选项”取消勾选“全局”,用到它的对象保留当前的颜色(含色调),之后不再跟着这个色板变化(同 Illustrator);专色一定是全局色板。色板面板可以用 Tab 进入,方向键在色板之间移动,Home/End 到第一个或最后一个,Enter 或 Space 应用(同单击一下)。
- 交换色板:面板菜单“打开色板库”读入 .ase 或 .json;“导出色板为 ASE”“导出色板库(JSON)”输出选取的色板,没有选取就输出全部。
- 渐变见渐变;一个对象上的多个填色和描边见外观面板。
渐变
- 渐变面板:“窗口 › 渐变”或 Ctrl+F9。点缩览图可把渐变应用到所选对象;“渐变色板”下拉菜单可选内置或已存的渐变,+(新建渐变色板)会把当前渐变存成色板,它也会出现在色板面板里。“填色或描边”决定应用到填色还是描边(与工具栏填色/描边方块上的 X 是同一个设置;没有描边时会创建 1 pt 的描边)。
- 类型:线性渐变、径向渐变、任意形状渐变。在线性和径向之间切换会保留色标;转换为任意形状渐变时,色标会变成放在对象上的色标点。
- 线性与径向:角度(−360 到 360°)、长宽比(径向,1–10000%)、⇄ 反向渐变。点渐变条可添加色标(最多 64 个),拖动可移动,把它往下拖出渐变条即可删除(至少保留 2 个);渐变条上方的菱形是中点,也可以拖动。选中的色标可以修改颜色、不透明度和位置,或用 🗑 删除。
- 任意形状:颜色来自色标(点模式)。用渐变工具在对象上点一下,就会在该处添加一个色标,颜色取自那个位置(最多 64 个)。选中的色标可以修改颜色、不透明度和扩展,或删除(至少保留 1 个)。面板的模式只有“点”,线模式暂时还没有。线条模式:先选取一个色标,再用渐变工具单击对象,新的点会连到选取的点后面(继续单击就是折线);Shift+单击=开始新的一条。颜色沿线段渐变再向外扩散;不在线上的点按点模式作用。删除线上的点时线随之缩短;切回点模式会移除所有线条。
- .:把上次使用的渐变应用到所选对象最前面的填色或描边(与工具栏的“渐变 (.)”按钮相同);默认是“白色,黑色”。
- 渐变工具 G:在所选对象上拖动,设置方向和长度(线性=起点到终点,径向=圆心到半径);Shift 限制为 45° 的倍数。没有渐变的对象会先套用上次使用的渐变。对象上的渐变批注者可以拖动原点、终点、旋转、色标和中点;径向渐变还有长宽比和焦点的控点。Ctrl+Alt+G 或“视图 › 隐藏渐变批注者/显示渐变批注者”可切换显示。渐变工具处于活动状态时,Delete(或 Backspace)只删除选中的色标或色标点;没有选中时什么都不做,不会删掉对象。
- 在对象上编辑渐变,永远不会改动色板本身(下拉菜单会显示“(已编辑)”)。每次修改是一个撤销步骤;拖动会合并成一步。
- 导出:SVG 中线性和径向渐变保持原生,任意形状渐变会变成嵌入的图像,并给出提示;PDF 中任意形状渐变会变成网格着色,色标的不透明度不会导出。DXF 和 CAD 工作区使用渐变的平均颜色。
外观面板
- “窗口 › 外观”或 Shift+F6。列出所选对象的描边和填色,最上面的在最前;每行显示颜色、渐变标记、描边宽度和不透明度,最后一行是对象的不透明度。一个对象可以有多个填色和描边(最多 64 项)。
- 眼睛隐藏或显示一个项目;拖动可调整顺序。选中一个项目后,可以修改它的颜色(渐变项目请在渐变面板里编辑)、描边宽度和不透明度,或把它上移或下移。
- 底部的按钮:添加新描边、添加新填色、清除外观(移除所有项目,以及对象的不透明度、混合模式和效果)、缩减至基本外观(只保留第一个描边和第一个填色)、复制所选项目、删除所选项目。所选对象彼此不同时(混合外观),只能使用添加、清除、缩减和对象不透明度。
- 标头:选取一个对象时显示它的种类:路径(矩形、椭圆等形状也是路径)、复合路径、复合形状、剪切组、文字、符号实例。
- 编组:选取一个编组时,标头是“编组”,下面有“内容”行。编组本身没有外观(Synhedra 还没有编组层级的填色和描边),单击“内容”才编辑编组里对象的外观,不会悄悄改到里面的对象。
- 效果:对象的效果列在不透明度上方(例如“fx 投影”)。单击名称重新编辑,✕ 删除。见效果。
效果
- “效果”菜单:路径 › 位移路径…、风格化 › 投影…、风格化 › 圆角…。效果是实时的:只改变显示,路径本身不变(同 Illustrator),之后可在外观面板修改或删除。每个对象最多 8 个效果,按顺序应用。
- 位移路径:轮廓向外(正值)或向内(负值)位移,连接可选斜接、圆角、斜角与斜接限制。
- 投影:不透明度、X/Y 位移、模糊、颜色;画在对象后面。Y 位移正值向上(Synhedra 坐标;Illustrator 对话框正值向下)。模糊以几个错开的半透明副本近似。
- 圆角:每个尖角锚点套用相同半径的圆角(过大时用放得下的最大半径)。
- 应用上一个效果 Shift+Ctrl+E:以相同参数再应用一次;上一个效果… Alt+Shift+Ctrl+E:用上次参数打开对话框。
- 距离单位为 pt,按画板比例换算;选取编组时应用到编组内的每个对象。
- 导出 SVG、PDF 与 DXF 不含效果(写出原始路径并提示)。羽化、高斯模糊等其他效果即将推出。
绘图模式
- 工具栏下方有三个按钮:正常绘图、背面绘图、内部绘图。Shift+D 依次切换(除非恰好选中一个有效的目标,否则会跳过内部绘图)。它们只影响用矩形、椭圆、钢笔、曲率、文字和直排文字工具绘制的新对象,不影响菜单命令或粘贴。重新加载页面后,模式会回到正常绘图。
- 背面绘图:新对象位于所选的最下面那个对象的正下方(在同一个编组和图层中);没有选取时位于最底部。
- 内部绘图:请先选取一条封闭路径(复合路径也可以)或一个剪切组;周围会出现虚线的角标记。你画的第一个对象会把目标变成剪切蒙版(蒙版保留自己的填色和描边),之后的对象会放进同一个剪切组。如果目标被删除,模式会回到正常绘图。
图层面板
- “窗口 › 图层”或 F7。由上到下列出图层、子图层、编组与对象,靠前的对象在上面。
- 眼睛切换显示(Alt 单击=只显示这个图层,再单击一次全部显示),锁头切换锁定,子图层跟着变暗,但各自的眼睛与锁头状态保留,上层恢复时跟着恢复。隐藏或锁定之后,选区中看不到或被锁住的对象会取消选择。双击名称改名。
- 轮廓模式:Ctrl 单击(Mac 用 ⌘)图层的眼睛,这个图层(含子图层)在轮廓模式与预览模式之间切换;眼睛变成空心,只改变显示,选区不变,可以撤销。
- 单击图层行设为当前图层,新对象画在这里。右侧的目标圆圈选取那个对象,或那个图层上全部可选的对象(Shift 加选或减选)。
- 把图层拖到另一个图层的上方、下方或里面(变成子图层);把对象拖到图层行上,移到那个图层;在同一个编组或同一个图层内拖动对象,调整前后顺序。Esc 取消拖动。
- 面板下方有定位对象、建立或释放剪切蒙版、创建新子图层、创建新图层、删除。0 与 Defpoints 图层不能删除;仍被符号或块定义(或布局)使用的图层也不能删除;删除有内容的图层前会确认。
- 用键盘操作:图层列表是一个 Tab 停靠点。↑↓ 移动,Home/End 到第一行或最后一行,→ 展开、← 收起(已收起时回到上一层),Enter 或 F2 改名,Space=目标圆圈(选中这一行的内容),Shift+Space 加选或减选。
- 面板菜单(≡):新建图层…、新建子图层…(创建后立刻打开图层选项)、“名称”的选项…、收集到新图层、释放到图层(顺序)、释放到图层(累积)、定位对象。“收集到新图层”会把所选对象(在同一个图层、不在编组内、未锁定)移到其图层顶部的新子图层中;没有选取对象时,会把突出显示的图层包进一个新的父图层。“释放到图层”会把突出显示的图层或编组(或选取的一个编组)中的每个对象各放到一个新子图层;“累积”则在每个子图层中再多加入一个对象(使用副本),原对象在最上面的子图层。
- 图层选项:从面板菜单打开,或在图层行名称以外的任何位置双击(双击名称是改名)。有名称、颜色(预设或自定义)、样板、显示、预览、锁定、打印和变暗图像至(0–100%;值会存储,但显示暂时还不会变暗)。样板会锁定图层、关闭打印,并在 SVG 和 PDF 导出中跳过该图层;取消勾选预览=轮廓模式。图层“0”不能改名。
- Ctrl+L:新建图层(放在当前图层上方并设为当前图层);要同时打开图层选项请用面板菜单的“新建图层…”。
路径查找器
- “窗口 › 路径查找器”或 Shift+Ctrl+F9。
- 形状模式:联集、减去顶层、交集、差集。直接单击按钮生成新的路径。按住 Alt 单击则建立实时的复合形状:原来的对象保留,可以用直接选择或隔离模式继续编辑,结果实时更新;“扩展”把它变成普通路径。面板菜单也有建立、释放与扩展复合形状。
- 路径查找器:分割、修边、合并、裁剪、轮廓、减去后方对象。
- 联集、分割、轮廓、修边、合并至少要选 1 个对象,其他要 2 个。编组先合成一个运算对象。选取中有锁定或隐藏的对象时不会执行;文字请先创建轮廓(Shift+Ctrl+O)。结果为空时图稿不变,并会提示。每个按钮是一个撤销步骤。
路径工具
- 宽度工具 Shift+W:沿着描边拖动,改变那一处的宽度,生成宽度配置文件。只作用于以 pt 为单位的矢量描边;出图线宽要先在描边面板改成 pt。描边面板的“配置文件”下拉有均匀、尾端渐细、起点渐细、透镜、菱形、单侧、凸起,手动拖出来的是“自定义(宽度工具)”。
- 橡皮擦 Shift+E(Eraser Tool):拖动擦除。默认是圆形笔刷,直径 10 pt,Alt 拖动改为矩形。有填色的封闭路径,被擦到的部分会被挖掉,剩下互不相连的部分各成一个对象;开放路径和没有填色的路径,被擦到的那一段被删除,剩下的每一段各成一个对象。文字、块和编组本身不处理。
- 连接工具(Join Tool,无单键):在两个开放端点之间来回刷过,把它们连起来。两条路径在端点附近交叉时,会在交点修剪多出来的尾巴,再连接起来;同一条路径的两端都刷到,就把它闭合。
- 虚线:描边面板勾选“虚线”,输入虚线与间隙长度。有两种模式:保留精确的虚线和间隙长度,或把虚线对齐转角与路径端点、微调长度以适应。描边还可以加箭头。虚线面板的结果会写成 DXF 线型。
- 位移路径:“对象 › 路径 › 位移路径…”。输入位移、转角(尖角、圆角、斜角)和尖角限制,勾选“预览”先看结果。位移的绝对值不超过 100000。向内缩得比形状还大时,结果为空,会有提示。
- 轮廓化描边:“对象 › 路径 › 轮廓化描边”把描边转成填色的轮廓,包含宽度配置文件、虚线和箭头。所选对象没有描边时会提示。
- 简化:“对象 › 路径 › 简化…”。调整“曲线精度”、“角点角度阈值”,或勾选“转换为直线”,勾选“预览”可实时查看结果。
- 连接工具、橡皮擦等工具在左侧工具栏,按住或展开工具组即可看到。
文字工具
- 文字工具 T 和直排文字工具(工具栏,无单键)。单击后做什么,取决于点在哪里:
- 点文字:点在空白处,那一点是第一行文字的基线起点。
- 区域文字:在空白处拖动(超过约 6 个屏幕像素)画出矩形文字框;或点在封闭路径的填色范围内或边上,那条路径会变成文字框。
- 路径文字:点在开放路径的描边附近(约 4 像素),文字沿着路径排列。
- 编辑:点在已有的矢量文字上,光标就放在那里继续输入。锁定或隐藏的对象不会被点中。
- 直排文字:用直排文字工具,文字竖向排列。
- 串接:文字框放不下时会出现溢出标记。单击标记,再拖出新的文字框,或单击另一个空的区域文字对象,文字就串接过去。
- 字符与段落:菜单“文字”打开字符和段落面板,设置字体、字号、行距、对齐等。旋转过的区域文字,文字按文字框的实际角度排列。
- 创建轮廓 Shift+Ctrl+O:把所选文字转成路径(在“对象”菜单)。转换后就不能再作为文字修改。
- 繁体中文:有避头尾处理,台湾习惯的居中标点不做挤压,保持全角宽度。
置入、导出与剪贴板
- 置入:“文件 › 置入…”(Shift+Ctrl+P)把 SVG、PDF 或 .ai 文件(兼容 PDF 的 Illustrator 文件)放进当前图面。“文件 › 打开…”(Ctrl+O)则是把文件打开为新文档。
- 导出:“文件 › 导出 SVG…”输出当前画板。“文件 › 转存 PDF…”(Ctrl+P)每个画板输出一页,可选矢量图稿,或选“打印图纸”(一个画板=一张图纸加一个锁定视口,应用打印样式与线宽);勾选“保留编辑能力”会把原生数据嵌入文件,再次读入时完整还原。PDF 与 SVG 中的剪切蒙版默认以剪裁路径输出,少数查看器会忽略它,这时勾选“展开剪裁”。DXF 在“文件”菜单。本站配置了云端硬盘时,“文件”菜单里还有“从云端硬盘打开…”“保存到云端硬盘…”和“将副本保存到云端硬盘…”(只读的图纸不能保存);见第三方云端硬盘。
- 导出为多种屏幕所用格式:“文件 › 导出为多种屏幕所用格式…”(Alt+Ctrl+E)。选全部、范围或个别的画板,或完整文档。每个格式行有缩放(0.5x–4x、512w、512h、72/150/300ppi 等)、后缀(@2x、-512w 之类会自动加上,可以修改)和格式:PNG、JPG、SVG 或 PDF。SVG 和 PDF 是矢量格式,按画板的实际大小导出,忽略缩放。可以设置前缀和背景颜色(透明、白、黑;PNG、JPG、SVG 和 PDF 都适用,SVG 和 PDF 会加一个满版的底色矩形)。有 JPG 行时可以设置“JPG 品质”(默认 80);JPG 没有透明度,所以透明背景会变成白色。多于一个文件时默认打包成一个 ZIP(“超过一个文件时打包为 ZIP”,最多 1000 个文件;总大小上限取决于这台机器的内存,是 128 MB、256 MB 或 512 MB);否则逐一下载。
- 导出为 PNG:“文件 › 导出为 PNG…”。选分辨率(72、150、300 或其他 ppi)、背景(透明、白、黑)与消除锯齿(无、图稿优化、文字优化),可以使用画板,或不使用画板、输出整份文档。
- PNG 的 72 ppi=1x,1 pt 是一个像素。单边超过 16384 像素时会等比缩小并提示。使用“导出为 PNG”时,多个文件逐一下载,不会打包成 zip。
- 剪贴板:Ctrl+C 拷贝、Ctrl+X 剪切、Ctrl+V 粘贴,另有贴在前面 Ctrl+F、贴在后面 Ctrl+B、就地粘贴 Shift+Ctrl+V、在所有画板上粘贴 Alt+Shift+Ctrl+V(都在“编辑”菜单)。在 Synhedra 内拷贝粘贴使用原生格式,不会失真。对外还会写入 SVG(浏览器支持时)和纯文本,所以可以粘贴到别的软件。
- 粘贴时依次尝试原生格式、SVG、文本中的 SVG、纯文本(变成文字对象)。纯文本如果只是网址或图片标签,不会处理,也不会联网去抓图。文本上限 1 MB。浏览器可能会先询问剪贴板的使用权限。
剪切蒙版、复合路径与符号
都在“对象”菜单,也可以在 AI 面板里用一句话操作。
- 剪切蒙版:“对象 › 剪切蒙版 › 建立”Ctrl+7,用最上层的对象剪裁其他对象(至少选两个对象)。“释放”Alt+Ctrl+7。“编辑内容”“编辑蒙版”分别选取被剪裁的内容或蒙版本身。嵌套的蒙版取交集,编组取并集。PDF、SVG 导出会保留。
- 复合路径:“对象 › 复合路径 › 建立”Ctrl+8 把多条路径合成一个对象,孔洞的方向会自动调整;“释放”Alt+Shift+Ctrl+8。属性面板的“填色规则”可选非零或奇偶。
- 连接与平均:“对象 › 路径 › 连接”Ctrl+J 把选中的开放端点接起来。用直接选择工具恰好选中两个开放路径的端点锚点时,连接的就是这两点:重合=合成一点,不重合=补一段直线;同一条路径的两端=闭合。“平均…”Alt+Ctrl+J 把选中的锚点对齐到平均位置。“平均并连接”Alt+Shift+Ctrl+J 把两个端点移到中点,再合成一点。
- 符号面板:“窗口 › 符号”Shift+Ctrl+F11。选取图稿后按 F8(或面板的 +)新建符号,可选静态或动态。选区里有剪切蒙版或复合形状时,会展开成普通路径(蒙版实际剪切),实例的外观和原来的图稿相同,但在符号里不能再编辑蒙版或复合形状的子项;对话框会先说明。复合形状的结果算不出来时不会创建符号。把缩览图拖到画布,或点“置入符号实例”放实例。面板菜单还有复制、替换、删除符号、符号选项、清除覆盖,以及导入、导出符号库(JSON)。
- 编辑符号:面板的“编辑符号”、双击缩览图或双击实例,进入隔离模式。完成按 Esc(或隔离栏的 ◀、双击空白处),所有实例一起更新。编辑中临时的编组与实例不能隐藏、删除或移动。编辑中 Ctrl+Z 逐步撤销,退到起点再按一次=放弃这次编辑;完成后整段编辑是一个撤销步骤。
- 断开链接:“对象 › 符号 › 断开符号链接”把实例变回普通对象。
- 动态覆盖:动态符号的实例可以各自覆盖外观。用直接选择点到实例里的某个子对象,再在属性面板改填色或描边,改的只是这个实例;“清除覆盖”恢复原样。动态符号不能包含文字。
- 符号喷枪 Shift+S:先在符号面板点一个符号,再沿着拖动的轨迹,在画笔范围内放一批实例。双击工具打开选项,调直径、密度、散布、大小与旋转的随机程度和随机种子。同一组参数加同一个种子会得到相同的结果,但跨设备不保证完全一致,要重现请保存喷洒出来的实例。
- DXF 如何处理符号,见2D 绘图 › DXF 注意事项。
标尺、参考线与网格
这些开关在“视角”菜单。它们只改变显示,不存进文件,也不进入撤销(同 Illustrator),由这台电脑的浏览器记住。
- 标尺 Ctrl+R:从上方标尺往下拖=水平参考线,从左侧标尺往右拖=垂直参考线。
- 参考线:Ctrl+; 显示或隐藏,Alt+Ctrl+; 锁定或解锁(锁定时不能选择或移动参考线)。“建立参考线”Ctrl+5 把选中的路径变成参考线(文字、块、图像不行);“释放参考线”Alt+Ctrl+5 把参考线变回普通路径;“清除参考线”删除全部。未锁定时,参考线可以点选、移动、复制与删除。上限 1000 条、5 万个锚点。
- 网格 Ctrl+':显示或隐藏网格。“对齐网格”Shift+Ctrl+':移动时定界框的边或中心落在最近的网格线上(此时智能参考线停用)。“对齐点”Alt+Ctrl+':拖动的点落在 2 px 内的锚点上。“对齐像素”:定界框左上角对齐 1 pt 的格子。
- 智能参考线 Ctrl+U 也会对齐参考线,并显示间距参考线:同一行(或列)中与相邻对象的间距等于另外两个相邻对象的间距,或正好位于前后两个对象中间时,用带短刻度的线标出相等的间距。
吸管、形状生成器、铅笔与画笔
工具都在左侧工具栏。双击工具按钮打开该工具的选项。每次松开鼠标是一个撤销步骤。锁定、隐藏或位于锁定图层上的对象不会被修改。
- 吸管工具 I:有选中对象时,点另一个对象,把它的外观应用到选中的对象;Shift+点只取颜色(应用到当前的填色或描边);Alt+点把选中对象的外观应用到被点的对象。没有选中时,取样为工具栏的填色与描边,供之后绘制的对象使用。选项可以勾选要取样的项目:外观、填色、描边、字符样式、段落样式。锁定但可见的对象也能取样。
- 形状生成器工具 Shift+M:先选中重叠的形状,再拖过若干区域=合并成一个形状;Alt+拖=删除这些区域;Shift+拖出矩形=框内的区域一次合并。新形状使用当前填色。上限 200 个对象、2 万个锚点。
- 铅笔工具 N:自由绘制一条路径。选项:保真度、为新铅笔描边填色、保持所选、端点在此范围内时闭合路径、编辑所选路径(在选中路径附近绘制=重画那一段)。按住 Alt 画完会闭合。
- 平滑工具:选中路径后沿着它拖动,那一段变平滑。路径橡皮擦工具:选中路径后沿着要擦除的部分拖动。两者都没有单键快捷键。
- 画笔工具 B:画出应用画笔的描边。“窗口 › 画笔”F5 打开画笔面板:基本、3 pt 圆形、5 pt 平头 45°、锥形。选中路径后点画笔即应用;“移去画笔描边”改回普通描边。
- 斑点画笔工具 Shift+B:画出的是填色的形状(颜色取当前描边色),会和重叠、填色相同且没有描边的路径合并。选项:保持所选、仅与所选对象合并、大小。[、] 调整画笔大小。
- 很长的笔画会先减少采样点(最多 4000 点)。
快捷键
| 按键 | 操作 | 状态 |
|---|---|---|
| Ctrl+Z、Shift+Ctrl+Z | 还原、重做(Illustrator 的重做是 Shift+Ctrl+Z) | 可用 |
| Ctrl+G、Shift+Ctrl+G | 编组、取消编组 | 可用 |
| Ctrl+2、Alt+Ctrl+2 | 锁定、解锁全部 | 可用 |
| Ctrl+3、Alt+Ctrl+3 | 隐藏、显示全部 | 可用 |
| Ctrl+A、Shift+Ctrl+A | 全选、取消选择 | 可用 |
| Ctrl+]、Shift+Ctrl+]、Ctrl+[、Shift+Ctrl+[ | 前移一层、置于顶层、后移一层、置于底层 | 可用 |
| Ctrl+D | 再次变换 | 可用 |
| Ctrl+U | 智能参考线 | 可用 |
| Shift+Ctrl+B | 显示或隐藏定界框 | 可用 |
| Ctrl+H | 隐藏边缘 | 可用 |
| Ctrl+Y | 整份文档的轮廓模式(单个图层:在图层面板 Ctrl 单击眼睛) | 可用 |
| 方向键、Shift+方向键、Alt+方向键 | 微移、十倍微移、先复制再微移 | 可用 |
| Enter | “移动”对话框 | 可用 |
| Esc、Delete | 取消选择、删除 | 可用 |
| Ctrl+9 | 显示或隐藏命令行(可在那里使用 CAD 命令) | 可用 |
| Tab、Shift+Tab | 隐藏或显示全部面板;隐藏或显示工具栏以外的面板(同 Illustrator;焦点在按钮或输入框时照常移动焦点) | 可用 |
| Ctrl+C、Ctrl+X、Ctrl+V、Ctrl+F、Ctrl+B | 复制、剪切、粘贴、贴在前面、贴在后面 | 可用 |
| Shift+Ctrl+V、Alt+Shift+Ctrl+V | 就地粘贴、在所有画板上粘贴 | 可用 |
| Ctrl+O、Shift+Ctrl+P、Ctrl+P | 打开(新文档)、置入、转存 PDF | 可用 |
| Shift+Ctrl+O | 创建轮廓(文字转成路径) | 可用 |
| Ctrl+R | 显示或隐藏标尺 | 可用 |
| Ctrl+;、Alt+Ctrl+; | 显示或隐藏参考线、锁定参考线 | 可用 |
| Ctrl+5、Alt+Ctrl+5 | 建立参考线、释放参考线 | 可用 |
| Ctrl+'、Shift+Ctrl+'、Alt+Ctrl+' | 网格、对齐网格、对齐点 | 可用 |
| Alt+Shift+Ctrl+J | 平均并连接 | 可用 |
| F5、[、] | 画笔面板、斑点画笔大小 | 可用 |
| Ctrl+7、Alt+Ctrl+7 | 建立、释放剪切蒙版 | 可用 |
| Ctrl+8、Alt+Shift+Ctrl+8 | 建立、释放复合路径 | 可用 |
| Ctrl+J、Alt+Ctrl+J | 连接、平均 | 可用 |
| F8、Shift+Ctrl+F11 | 新建符号、符号面板 | 可用 |
| X、Shift+X、D、/、, | 切换填色或描边在前、互换填色与描边、默认填色和描边、无、颜色(回到上次的颜色) | 可用 |
| . | 应用上次的渐变 | 可用 |
| Ctrl+F9、Shift+F6 | 渐变面板、外观面板 | 可用 |
| Ctrl+Alt+G | 显示或隐藏渐变批注者 | 可用 |
| Shift+D | 切换绘图模式(正常、背面、内部) | 可用 |
| F6、F7、Shift+Ctrl+F9 | 颜色面板、图层面板、路径查找器 | 可用 |
| Alt+Ctrl+E | 导出为多种屏幕所用格式 | 可用 |
| Ctrl+L、Ctrl+K、Ctrl+E | 新建图层、首选项 › 常规、导出为(PNG) | 可用 |
| Shift+Ctrl+E、Alt+Shift+Ctrl+E | 应用上一个效果、上一个效果… | 可用 |
此表为手工维护(来源:keys.ts 中的 vectorCombo 与 Tab 分派)。尚未完成的 Illustrator 组合键会被拦截,避免浏览器执行其他动作;状态栏会显示提示。
Illustrator 对照
| Illustrator | 这里 | 状态 |
|---|---|---|
| 选择、直接选择、编组选择工具 | 相同 | 可用 |
| 矩形、椭圆工具 | 相同,带有实时形状属性 | 可用 |
| 旋转、镜像、缩放工具 | 相同 | 可用 |
| 画板工具 | 相同,默认为 A4 | 可用 |
| 抓手、缩放工具 | 相同 | 可用 |
| 定界框、隔离模式、智能参考线 | 相同(智能参考线为基本版) | 可用 |
| 对象:编组、锁定、隐藏、排列、再次变换 | “对象”菜单与快捷键 | 可用 |
| 填色与描边 | 属性面板 | 可用 |
| 文件:导入、导出 DXF | “文件”菜单 | 可用 |
| 窗口 › AI | 打开 AI 面板;“窗口 › AI 画布(图像/手绘)”打开 AI 画布 | 可用 |
| 文字工具(点文字、区域文字、路径文字、直排文字) | 见文字工具 | 可用 |
| 宽度工具、橡皮擦、套索、连接工具、位移路径、轮廓化描边、简化 | 见路径工具 | 可用 |
| 置入、导出 SVG/PDF、剪贴板 | 见置入、导出与剪贴板 | 可用 |
| 剪切蒙版、复合路径、连接与平均、符号面板、符号喷枪 | “对象”“窗口”菜单与快捷键,见说明 | 可用 |
| 钢笔、添加锚点、删除锚点、锚点、曲率工具 | 见钢笔工具 | 可用 |
| 填色与描边、拾色器、颜色面板、色板面板(含全局色板、颜色组、.ase) | 见填色、描边与颜色 | 可用 |
| 图层面板 | 见图层面板 | 可用 |
| 路径查找器(含实时复合形状) | 见路径查找器 | 可用 |
| 导出为多种屏幕所用格式、导出为 PNG | 见置入、导出与剪贴板 | 可用 |
| 直线段工具 | \,见绘图与选取 | 可用 |
| 渐变面板与渐变工具(线性、径向、任意形状的点) | 见渐变 | 可用 |
| 外观面板(多个填色和描边) | 见外观面板 | 可用 |
| 绘图模式(正常、背面、内部) | 见绘图模式 | 可用 |
| 图层面板菜单、图层选项 | 见图层面板 | 可用 |
| 效果:位移路径、投影、圆角(实时)、任意形状渐变的线条模式 | 见效果与渐变 | 可用 |
| 其他效果(羽化、高斯模糊、3D…) | 即将推出 | |
| 轮廓模式(图层) | 图层面板 Ctrl 单击眼睛,见图层面板 | 可用 |
| 轮廓模式(整份文档,Ctrl+Y) | 视图 › 轮廓/预览(只改显示,不存入文件) | 可用 |
| 标尺、参考线、网格、对齐 | 见标尺、参考线与网格 | 可用 |
| 吸管、形状生成器、铅笔、平滑、路径橡皮擦、画笔、斑点画笔、画笔面板、平均并连接 | 见吸管、形状生成器、铅笔与画笔 | 可用 |